"Traceflow request timeout. Please retry." ERROR seen when running Traceflow in NSX UI
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"Traceflow request timeout. Please retry." ERROR seen when running Traceflow in NSX UI

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Article ID: 375417

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Updated On: 07-02-2025

Products

VMware NSX

Issue/Introduction

  • In the NSX manager UI, Plan and Troubleshoot, Traffic Analysis, Traceflow, when a new traceflow is triggered, the following error is displayed:

    "Traceflow request timeout. Please retry."

  • In the NSX manager log /var/log/proton/nsxapi.log, the following exception is seen:

    INFO Traceflow-Timeout-Thread TraceflowObservationServiceImpl 5108 POLICY [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Creating observation in policy ########-####-####-####-######dc04 from config TraceflowConfig{segmentPortPath='/infra/segments/ns-arb-ft-dev-int-segment/ports/default:########-####-####-####-########fa', timeout=10, packetData=null, isTransient=true, epPath=null, startTime=1723095439855}[policyPath=/infra/traceflows/########-####-####-####-######3d8c, markedForDelete=false]

    WARN Traceflow-Timeout-Thread TraceflowCacheManager 5108 MONITORING [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="manager"] Encountered exception when running timeout executor java.lang.NullPointerException: null at com.vmware.nsx.management.policy.traceflow.service.common.TraceflowServiceUtils.toNatRulePath(TraceflowServiceUtils.java:371) ~[?:?]

Environment

VMware NSX version lower than 4.2.1

Cause

There is a NAT rule without an intent path in the Tracepath/Traceflow, Traceflow will fail when there is a NAT rule with no intent path.

Once the Traceflow which failed, due there being no intent path in the NAT rule issue occurs, all subsequent Traceflow's go into a pending state, waiting for the failed Traceflow to complete.

Resolution

This issue is resolved in VMware NSX 4.2.1, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

The workaround the issue:

  1. Remove all the Traceflows via the policy API before user trying to initiate a new Traceflow:

    1. Get all the Traceflows via REST API:

      GET https://<mgr-ip>/policy/api/v1/infra/traceflows

    2. You can get the ID of the Traceflows from the RESTAPI response.

  2. Delete all the Traceflows listed in the previous REST API response, one by one, using the following DELETE REST API:

    DELETE https://<mgr-ip>/policy/api/v1/infra/traceflows/<traceflow-id>

  3. Once all the failed and pending Traceflows are deleted, Traceflow should now work via the UI.

Additional Information

If this KB did not help resolve your issue, you can review the following KB for further troubleshooting steps: Troubleshooting NSX Traceflow