Managing snapshot in Aria lifecycle manager fails to load the snapshot with "failed to fetch snapshot information"
search cancel

Managing snapshot in Aria lifecycle manager fails to load the snapshot with "failed to fetch snapshot information"

book

Article ID: 374744

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Unable to manage the snapshot of the products. We can see the below errors in vrlcm logs.


Path:/var/log/vrlcm/vrlcm-server.log

  "vmid" : "1111-2222-3333-4444-5555555555",
  "transactionId" : null,
  "tenant" : "default",
  "createdBy" : "root",
  "lastModifiedBy" : "root",
  "createdOn" : Date of creation,
  "lastUpdatedOn" : Date of creation,
  "version" : "8.1.0.0",
  "vrn" : null,
  "envId" : "globalenvironment",
  "productId" : "vidm",
  "nodeIp" : "X.X.X.X",
  "tenantId" : "",
  "vcSnapshotId" : "snapshot-172451",
  "productSnapshotId" : "1111-2222-3333-4444-5555555555",
  "parentProductSnapshotId" : null,
  "withMemory" : false,
  "quiesce" : false,
  "shutdown" : true,
  "exists" : false,
  "currentSnapshot" : false,
  "snapshotPrefix" : "Name of snapshot",
  "vcSnapshotName" : "Name of snapshot",
  "snapshotGeneratedTime" : null,
  "description" : ""
}, {

2024-08-02 14:23:45.954 ERROR [http-nio-8080-exec-9] c.v.v.l.l.c.SnapshotInventoryController -  -- Exception occurred while trigger product snapshot Request : java.lang.NullPointerException

Environment

Aria lifecycle manager 8.x

Cause

There is a null entry for the snapshot generated time in the database

Resolution

  1. Take offline snapshot of the aria lifecycle manager

  2. Login to the SSH terminal of vRLCM appliance.

  3. Access the psql (database client) prompt:

    psql -U postgres -h localhost -d vrlcm

  4. Run the below command :

    UPDATE vm_snapshot_inventory SET snapshotgeneratedtime='time' WHERE vmid IN ('ID can be obtained from the vrlcm log');

Additional Information

Aria Suite LCM follows the same best practices for using VMware snapshots in the vSphere environment