Inventory Sync Failure for Aria Operations for Logs with Error Code: LCMVRLICONFIG40090
search cancel

Inventory Sync Failure for Aria Operations for Logs with Error Code: LCMVRLICONFIG40090

book

Article ID: 374375

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

This article addresses inventory synchronization failures in VMware Aria Operations for Logs (vRealize Log Insight)  due to invalid root user credentials

- Error Code: LCMVRLICONFIG40090
- VMware Aria Operations for Logs root password is invalid. Provide right credentials and retry.
- SSH authorization failed with provide root password for < Aria Operations for Logs IP Address > .Please verify the credentials and retry




Error Log:

com.vmware.vrealize.lcm.common.exception.EngineException: SSH authorization failed with provide root password for <Aria Operations for Logs IP Address> .Please verify the credentials and retry
 at com.vmware.vrealize.lcm.plugin.vrli.VrliImportEnvironmentTask.execute(VrliImportEnvironmentTask.java:333)
 at com.vmware.vrealize.lcm.automata.core.TaskThread.run(TaskThread.java:62)
 at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
 at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
 at java.base/java.lang.Thread.run(Unknown Source)

Environment

VMware Aria Operations for Logs 8.x
VMware Aria Suite Lifecycle Manager 8.x

Cause

This issue typically occurs due to incorrect credentials or if the root account is locked out after multiple failed login attempts

Resolution

Follow the below steps to resolve the issue

Verify Root Credentials:

  1. Open an SSH session to Aria Operations for Logs as the root user and existing password
  2. If the root login fails or the account is locked. Wait for 15 mins for the root to get unlock or to reset the root password follow the steps from Article: How to reset the root password in VMware Aria Operations for Logs (formerly VMware vRealize Log Insight)  
  3. After resetting the root password, follow the KB article on "Changing passwords on VMware Aria Operations for Logs using VMware Aria Suite Lifecycle" to Add the new password in the Lifecycle Manager.
  4. Validate the passwords by following the KB "Validating what passwords are being used per VMware Aria Suite Product in VMware Aria Suite Lifecycle."
  5. Click on Retry or Re-trigger the inventory sync.

If the root login is success from Shell (SSH)

  1. Refer and validate this article "Viewing passwords stored in VMware Aria Suite Lifecycle (vRealize Suite Lifecycle Manager) Locker" to check the stored password.
  2. If the password is incorrect, click "Edit password," update with the correct one, and save.
  3. Validate the passwords  by following the KB "Validating what passwords are being used per VMware Aria Suite Product in VMware Aria Suite Lifecycle."
  4. Click on Retry or Re-trigger the inventory sync.