The "NSX audit not connected compute managers" error occurs when the Compute Manager connection in NSX is in a DOWN state.
*If after rebooting the SDDC and Compute Manager, the pre-check still fails, perform a rolling reboot of the nsx managers leaving the manager that is responsible for the VIP for last.