Unable to delete profiles in DX UIM Infrastructure Manager
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Unable to delete profiles in DX UIM Infrastructure Manager

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Article ID: 371853

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Profiles are in use in the DX UIM Infrastructure Manager (IM). When attempting to delete one of these profiles in the Manage Profiles menu, it appears to delete the profile, but when opening the menu again or listing the profiles, it remains.

Environment

  • Infrastructure Manager 4.10, 20.4.x, 23.4.x

Cause

Profiles may be created with a trailing space.  These spaces are not visible in the Manage Profiles menu:

Profiles with this space are not able to be deleted by IM.  When you 'View Profiles' you can also see that the profile has not been deleted.

You can see the space in the filename used to store the profile:

The IM .pcf files are stored in the /hub/profiles folder on the system where you are running the IM.

The security.cfg file also contains this space in the profile name.

Resolution

It is possible to edit the security.cfg and profile filename to remove the space.  This will allow you to delete the profile.  Editing the security.cfg file requires the secedit tool.  

WARNING: Editing the security.cfg file manually can create problems logging into the UIM.  DO NOT MANUALLY EDIT THIS FILE.

You can use the following steps to make the required changes:

  1. Download the secedit file (Find the link in the Additional Information section of this article).
  2. Copy the secedit file to the hub directory.
  3. Create a backup folder in the hub directory.
  4. Copy all security.* files in the hub directory to this new backup folder.
  5. Using a command prompt opened as administrator, run the "secedit7.0.exe" command.
    • Enter the administrator username and password
    • Notepad will open and load the security.cfg file
  6. Edit the security.cfg file as follows:
    • Increment the version
      • Your file will have something similar to the following at the very top:  
        <setup>
           version = 370700
      • Edit this so that the version number is increased:
        <setup>
           version = 370701
    • Locate the profile and remove the space:
      • You'll find the profile name with a space at the end:
        <test profile with space >
              size = 0
        </test profile with space >
      • Edit these lines to remove the trailing space:
        <test profile with space>
              size = 0
        </test profile with space>
    • Close and save the file
  7. Open the hub/profiles directory and edit the file name to remove the trailing space.
    • From:
      "test profile with space .pcf"
    • To:
      "test profile with space.pcf"
  8. After a minute or so, open IM and log in.
  9. You should now be able to view the profiles and delete "test profile with space".


An additional unexpected result may occur as well if you find that you can successfully delete the profile but it returns to the primary.

If that occurs after making the changes above, follow only the first part of the KB Article referenced below.

Login to the Primary hub machine and open the IM.

1. Select the hub probe and press Ctrl-P to open the Probe utility
2. Select the hubsec_setup_put callback
3. Set the key to:
    secure_callbacks_from_primary_hub_only
4. Set the value to:
    yes
5. Press the green arrow to execute the callback

When this key is set to yes: the primary hub propagates security changes to ALL hubs in the domain.

Then restart the hub.

Then delete the profile you're trying to delete.

Check back in a few days if the profile remains deleted.

security.cfg file keeps getting corrupted - need to find a way to notify if this file gets changed

 

Additional Information

You can find the secedit tool attached to the following article:

Use the secedit utility in DX UIM to recover or modify the hub security.cfg