Performance issues on a CEIP enabled vCenter that has no network connectivity
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Performance issues on a CEIP enabled vCenter that has no network connectivity

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Article ID: 371459

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

VMware’s Customer Experience Improvement Program (CEIP) enables VMware to provide environments with a proactive, reliable, and consistent vSphere environment and experience. CEIP collects configuration, feature usage, and performance information.

CEIP participation requires connection from the vCenter Server to https://vcsa.vmware.com:443 to send telemetry and to make use of the cloud connected services. If the system uses a firewall or a proxy to connect to the Internet, specify a firewall or a proxy rule allowing outbound traffic to https://vcsa.vmware.com:443/ph/api/*

    If there is no network connectivity between the vCenter Server and VMware's server, CEIP participation will not function appropriately and can cause performance issues within vCenter. 

    • vCenter may run slower
    • The refresh button in the upper right corner will appear to be refreshing all the time
    • From the Google Chrome developer tools, constantly failing API calls will be observed

    Cause

    Since CEIP participation requires connection from the vCenter Server to https://vcsa.vmware.com:443, the program will constantly attempt to establish connection.

    Resolution

    In environments where there is no outside network connectivity, it is recommended to disable the CEIP program.

    Additional Information