Powering on IDM cluster fails when trying to start networking on the individual servers
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Powering on IDM cluster fails when trying to start networking on the individual servers

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Article ID: 370458

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Identity Manager servers are shut down and fail during the vRSLCM power up process request.
  • Looking at the VM Summary page shows the VM is powered on, but no IP address or FQDN is assigned
  • Accessing through the console the network service is not starting
    • systemctl status network
    • [ ~ ]# systemctl status network
      ● network.service - LSB: Bring up/down networking
         Loaded: loaded (/etc/rc.d/init.d/network; generated)
        Drop-In: /etc/systemd/system/network.service.d
                 └─override.conf
         Active: inactive (dead)
           Docs: man:systemd-sysv-generator(8)
  • Error on the console indicating no networking detected

Cause

Root partition of the server is out of space due to files getting too large.

With no space available the server is not able to write the configuration needed by the vRSLCM start up process for the Identity Manager cluster.

Resolution

  1. Check the space in each of the servers and confirm none of the partitions are full.
    • Run command "df -h" to check the space.
      • root@idmserver01 [ ~ ]# df -h
        Filesystem                     Size  Used Avail Use% Mounted on
        /dev/root                      8.8G  8.6G     0 100% /
        devtmpfs                       3.0G     0  3.0G   0% /dev
        tmpfs                          3.0G   12K  3.0G   1% /dev/shm
        tmpfs                          3.0G  792K  3.0G   1% /run
        tmpfs                          3.0G     0  3.0G   0% /sys/fs/cgroup
        tmpfs                          3.0G   36K  3.0G   1% /tmp
        /dev/sda1                      123M   24M   93M  21% /boot
        /dev/mapper/tomcat_vg-horizon   20G  3.3G   16G  18% /opt/vmware/horizon
        /dev/mapper/db_vg-db           9.7G  339M  8.9G   4% /db
        tmpfs                          597M     0  597M   0% /run/user/0
        tmpfs                          597M     0  597M   0% /run/user/1002
        tmpfs                          597M     0  597M   0% /run/user/1001
  2. If any of the directories are unusually full (at 100% Usage) then locate what is filling up the space
    • Command "du -h -d1" to start narrowing down where the space issues are located.

  3. Once the files causing the issue have been identified you will want to get them moved/compressed/deleted to free up the space on each of the servers.

  4. When all the servers have acceptable space available you want to shut the Identity Manager servers down, then go into the vRLCM and initiate a power on of the Identity Manager cluster.

Additional Information

If space is not your issue, you can get a similar error message in the console caused by the problem outlined in the knowledge article 336785.