Fatal Error While Connecting to Console
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Fatal Error While Connecting to Console

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Article ID: 369880

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Console UI displays:
    • Fatal Error
    • Network error while trying to communicate with Carbon Black App Control Server
    • Error: Could not connect to host
  • Serverlog.bt9 shows error:
    Connection attempt failed: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

Environment

  • App Control Server: All Supported Versions

Cause

  • Application unable to communicate with the SQL Server specified
  • ODBC Drivers or SQL Native Client uninstalled

Resolution

  1. Login to the App Control Console server
  2. Navigate to C:\Program Files (x86)\Bit9\Parity Server (or wherever Parity Server is installed)
  3. Open the file "shepherd.dsn" and note the Server that is listed
  4. Verify connection to the sql server / instance name. By default this uses port 1433
  5. Open programs and features (appwiz.cpl)
  6. Confirm the following applications are installed:
    1. "Microsoft SQL Server 2012 Native Client"
    2. "Microsoft ODBC Driver 13 for SQL Server"
    3. "Microsoft ODBC Driver 17 for SQL Server"

Additional Information

For additional steps for troubleshooting console unavailability please use these steps