Fatal Error While Connecting to Console
book
Article ID: 369880
calendar_today
Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Environment
- App Control Server: All Supported Versions
Cause
- Application unable to communicate with the SQL Server specified
- ODBC Drivers or SQL Native Client uninstalled
Resolution
- Login to the App Control Console server
- Navigate to C:\Program Files (x86)\Bit9\Parity Server (or wherever Parity Server is installed)
- Open the file "shepherd.dsn" and note the Server that is listed
- Verify connection to the sql server / instance name. By default this uses port 1433
- Open programs and features (appwiz.cpl)
- Confirm the following applications are installed:
- "Microsoft SQL Server 2012 Native Client"
- "Microsoft ODBC Driver 13 for SQL Server"
- "Microsoft ODBC Driver 17 for SQL Server"
Additional Information
For additional steps for troubleshooting console unavailability please use these steps
Feedback
thumb_up
Yes
thumb_down
No