"A problem was encountered while registering the provider", Registering a VASA Provider Fails
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"A problem was encountered while registering the provider", Registering a VASA Provider Fails

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Article ID: 368313

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Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

  • When trying to register VASA Provider on vCenter, the following error appears:  "A problem was encountered while registering the provider.”

  • vCenter has been upgraded to 8.x from 5.x
  • /var/log/vmware/vmware-sps/sps.log shows the following error:

SNI = null
multiVcSupported = true
port = null
serviceHost = null
vcGuid = XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX

Environment

vCenter 8.0

Cause

The vcGuid was appeared in uppercase letters which is the cause of the failure.

Resolution

  1. Update "instance.cfg" and "vpxd-service-spec.prop" to use lowercase letters for the vCenter GUID. 
       
       a.Take a snapshot of vCenter
       b.Open SSH connection to vCenter as root
       c.Edit "/etc/vmware-vpx/instance.cfg", update all uppercase letters to lowercase letters.
        # vi /etc/vmware-vpx/instance.cfg
        Change line "instanceUuid=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX" to "instanceUuid=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx"
       
       d.Edit "/etc/vmware-vpx/firstboot/vpxd-service-spec.prop", update all uppercase letters to lowercase letters.
        # vi /etc/vmware-vpx/firstboot/vpxd-service-spec.prop
        Change line "cmreg.serviceid=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX" to "cmreg.serviceid=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx"
         
  2. Update the SSO service registration with "lsdoctor -r" (option 3).

      a.Obtain lsdoctor tool from KB320837 and upload it into vCenter
      b.Run "python lsdoctor.py -r"

        Select option 3 when prompted (3. Replace individual service)
        Select the endpoint named "vcenterserver" - 
       
    **Please note when selecting Option 3 - Most templates are provided in the templates directory, and you should only need to select a template if it doesn’t exist.  If the template for your build of vCenter does not exist, you will be prompted to select one.  You should try to find the template that most closely matches your system.

  3. Reboot vCenter and register VASA provider
  4. Fix license tied to the vCenter

      a.Record current vCenter license key.
      b.Obtain current vCenter LDU ID with command:
        # /usr/lib/vmware-vmafd/bin/vmafd-cli get-ldu --server-name localhost
          yyyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyyyy

      c.Remove license associated with current LDU ID by command:

        # /opt/likewise/bin/ldapdelete -H ldap://localhost -D "cn=administrator,cn=users,dc=vsphere,dc=local" -w "password" "cn=AssetEntity_XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX-yyyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyyyy,cn=LicenseService,cn=Services,dc=vsphere,dc=local"

     Notes:
     Adjust dc=vsphere,dc=local to reflect the environment's SSO domain.
     Replace XXXXXXXX with the vCenter service ID from step 1 in capital letters
     Replace yyyyyyyy with the LDU ID from above Step 4.b

      d.Reboot vCenter and re-assign license.