Registering a VASA Provider Fails
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Article ID: 368313
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Updated On:
Products
VMware vSphere ESXi
Issue/Introduction
- When trying to register VASA Provider on vCenter, the following error appears: "A problem was encountered while registering the provider.”
- vCenter has been upgraded to 8.x from 5.x
- /var/log/vmware/vmware-sps/sps.log shows the following error:
SNI = null
multiVcSupported = true
port = null
serviceHost = null
vcGuid = XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
Cause
The vcGuid will appear in capital letters which is the cause of the failure.
Resolution
Update vpxd-service-spec.prop and instance.cfg to use lowercase lettering for the vCenter guid.
- Take snapshot of vCenter
- Open SSH connection to vCenter as root
- vi /etc/vmware-vpx/instance.cfg
- Change line instanceUuid=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX to reflect instanceUuid=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
- vi /etc/vmware-vpx/firstboot/vpxd-service-spec.prop
- Change line cmreg.serviceid=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX to reflect cmreg.serviceid=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
- Download lsdoctor https://knowledge.broadcom.com/external/article/320837/ and upload file into vCenter
- Run lsdoctor -r
- Selection option 3 when prompted
- Select the endpoint named "vcenterserver"
- Reboot vCenter and register vasa provider
Fix license tied to upper case vCenter
- Obtain vCenter LDU ID with command:
/usr/lib/vmware-vmafd/bin/vmafd-cli get-ldu --server-name localhost
- Remove uppercase license with command: (Adjust dc=vsphere,dc=local to reflect deployment domain name)
/opt/likewise/bin/ldapdelete -H ldap://localhost -D "cn=administrator,cn=users,dc=vsphere,dc=local" -w "password" "cn=AssetEntity_XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX-LDU-ID,cn=LicenseService,cn=Services,dc=vsphere,dc=local"
Note: Adjust dc=vsphere,dc=local to reflect the environment's SSO domain.
Reboot vCenter and re-assign license.
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