VMware Aria Operations High Availability (HA) stuck in "Failed to Deactivate" state
search cancel

VMware Aria Operations High Availability (HA) stuck in "Failed to Deactivate" state

book

Article ID: 345974

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • The purpose of the KB is to help troubleshoot the HA to fix cluster stability.


Symptoms:
  • The High Availability in Aria Operations is stuck in the "Failed to Deactivate" state which restricts any configuration change in the cluster like Certificate Renewal.
  • The Activate/Deactivate HA button is greyed out.
  • The cluster can still be in an Online state but it will not perform precisely.
image.png
 
 
 


Environment

VMware vRealize Operations 8.x

Cause

  • It can happen if the services fail to either Activate or Deactivate the HA.

Resolution

  • There is a workaround. 


Workaround:
  • Here are the steps to resolve this issue:
  1. Take the cluster Offline from the vRops admin UI.
  2. Take snapshots of all nodes. 
  3. SSH to all the nodes using the root credentials.
  4. Stop casa on all the nodes by running the command: service vmware-casa stop
  5. Open casa.db.script in text edit by using the command: vi /data/db/casa/webapp/hsqldb/casa.db.script
  6. Identify the ha_transition_state in the last line of the fileimage.png
  7. Change the value from "FAILED_TO_DEACTIVATE' to "NONE" on all the nodes. (Please note the above screenshot has been taken from Aria Operations version 8.12. The value will be "FAILED_TO_DISABLE" in earlier versions.)
  8. Save and close the file.
  9. Start casa on all the nodes by running the command: service vmware-casa start
  10. Bring the cluster online from the admin UI.


Additional Information

How to enable/disable HA when the option is not available in vRealize Operations Manager UI

Impact/Risks:
  • It will impact the stability of the cluster which will in turn restrict configuration changes like Certificate renewal.
image.png