Usage Meter is unable to transmit usage data to Cloud Partner Navigator portal, and it gives an error: Test failed due to "Http failure response for https://www.example.example.com: 502 Bad Gateway". Please open a ticket with VMware support.
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Article ID: 345970
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Updated On:
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Products
VCF Operations/Automation (formerly VMware Aria Suite)
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Issue/Introduction
The connection between Usage Meter and Cloud Partner Navigator portal should work:
However, Usage Meter is unable to send usage data to the Cloud Partner Navigator portal due to a connectivity issue with the proxy:
Note :
If you are not using a proxy and encounter this error, it may indicate an SSL certificate issue, as outlined in the relevant knowledge base article .
If proxy is not being used, we might also face this issue if the port 443 between the usage meter and Cloud Partner Navigator is not open.
Environment
VMware vCloud Usage Meter 4.x
Cause
The Usage Meter is unable to connect to the cloud due to the proxy configuration, as the "Anonymous" user is being used for proxy authentication.
Resolution
There is no resolution available at this time; however, a workaround is available.
Workaround : If you are using an HTTPS/HTTP proxy, please follow the steps below:
Log in to the VAMI page of Usage Meter as the root user.
Navigate to the Networking tab.
Disable all proxy configurations from the VAMI page.
Continue disabling the configurations until all are disabled, then refresh the page.
Re-enable the HTTPS/HTTP proxy, but this time, use root credentials instead of the anonymous user when saving the configuration.
Restart the Usage Meter appliance from the vCenter.
Please attempt to send the usage data from Usage Meter to Usage Insight at this time.
Additional Information
Impact/Risks: The usage data will not be transmitted to the Cloud Partner Navigator (CPN) portal, and as a result, reports will not be generated.
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