Usage Meter is not able to send the usage data to Cloud Partner Navigator/Usage Insight, getting the error "Http failure response.....502 Bad gateway:
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Article ID: 345970
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Updated On:
Products
VMware Aria Suite
Issue/Introduction
The connection between Usage Meter and Usage Insight(Cloud Partner Navigator Portal) should work.

Symptoms:
Usage Meter is not able to send the usage data to the Cloud Partner Navigator portal due to the connectivity issue with the proxy.

Environment
VMware vCloud Usage Meter 4.x
Cause
The Usage Meter cannot connect to the cloud because of the proxy configuration, as the "Anonymous" user is used to configure the proxy.

Resolution
There is no resolution as of now. There is a workaround.
Workaround:
If you are using the HTTPS/HTTP proxy, please perform the below-mentioned steps.
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Open the VAMI page of Usage Meter as a "root" user.
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Go to the networking Tab.
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First, disable all the proxy configurations from the VAMI page
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Try disabling till you get all as disabled, then refresh the page.
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Enable the HTTPS/HTTP proxy, and instead of saving with an "anonymous" user, use the "root' credentials.

Try sending the usage data from Usage Meter to Usage Insight now.
Additional Information
Impact/Risks:
The usage data will not be sent to the Cloud Partner Navigator portal(CPN) and the reports will not be generated.
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