EAM service down Alert is generated on NSX
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EAM service down Alert is generated on NSX

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Article ID: 345803

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Updated On: 04-24-2025

Products

VMware NSX

Issue/Introduction

Title: Alarm for ESX Agent Manager (EAM) service down on compute manager
Event ID: ESX Agent Manager (EAM) service on compute manager UUID is down
Added in release: 3.0.0

Alarm Description

  • Impact: If ESX Agent Manager (EAM) service not running and user has configured Host Based deployments at NSX side then EAM Agent/Service VM won't be installed if any new ESX Host added into cluster.

Cause

Every 3 minutes, NSX checks for EAM status for all host-based service deployments on vCenter.

If NSX doesn't get a response from EAM Server, it raises an alarm.

Resolution

Maintenance window required for remediation? -- No

Start the ESX Agent Manager (EAM) service on vCenter. SSH into vCenter and invoke the command:
service-control --start vmware-eam

If EAM alarms are triggered due to no apparent EAM issues, follow resolution in the KB Unable to resolve EAM Status Down alarm in NSX-T

Note: May also have to restart the Proton service on the NSX manager to be able to resolve it.

Additional Information

This alarm could also be indicative of communication issues between vCenter and the NSX Manager(s), such as DNS forward and reverse lookups for the NSX Managers and Cluster VIP.  See Cannot edit Compute Manager in NSX UI - error "FQDNs are not configured for nodes IPs [#.#.#.#]. (Error code: 90335)" for details.

Other KBs with known issues related to ESX Agent Manager (EAM):

EAM service down Alarm is generated on NSX with multiple VCs registered

NSX Manager reports "EAM Status Down" Alarm comes up and gets resolved itself after few minutes