EAM service down Alert is generated on NSX
search cancel

EAM service down Alert is generated on NSX

book

Article ID: 345803

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

Title: Alarm for ESX Agent Manager (EAM) service down on compute manager
Event ID: ESX Agent Manager (EAM) service on compute manager UUID is down
Added in release: 3.0.0

Alarm Description

  • Impact: If ESX Agent Manager (EAM) service not running and user has configured Host Based deployments at NSX side then EAM Agent/Service VM won't be installed if any new ESX Host added into cluster.

Logs to check:

  • You can check /var/log/proton/nsxapi.log of NSX manager regarding EAM status polling details,
    Example:
    EamPollingThread EamServiceImpl 2165083 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] GetEamStatus for cmId ########-####-####-####-############
    EamPollingThread EamServiceImpl 2165083 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Getting all agencies in EAM for cmId ########-####-####-####-############

     

  • /var/log/cm-inventory/cm-inventory.log can be checked to confirm the compute manager connection status during the issue timestamp,
    #grep -i 'COMPUTE_MANAGER_CONNECTION_STATUS_DOWN' /var/log/cm-inventory/cm-inventory.log | awk '{print $1, $2}'
    connection_status: COMPUTE_MANAGER_CONNECTION_STATUS_DOWN
    2025-01-25T20:07:32.895Z INFO
    connection_status: COMPUTE_MANAGER_CONNECTION_STATUS_DOWN
    2025-01-25T20:08:02.904Z INFO
    

     

  • You can check /var/log/vmware/eam/web/loacal_access.log of vCenter server to confirm if the EAM status polling requested sent from NSX has reached VC and if the same was processed further.
    [tomcat-http--35] "POST /eam/sdk/ HTTP/1.1" 200 377 [Processing time 4 msec] "VMware vim-java 1.0"
    [tomcat-http--2] "POST /eam/sdk/ HTTP/1.1" 200 377 [Processing time 4 msec] "VMware vim-java 1.0"
    [tomcat-http--27] "POST /eam/sdk/ HTTP/1.1" 200 377 [Processing time 4 msec] "VMware vim-java 1.0"
    [tomcat-http--34] "POST /eam/sdk/ HTTP/1.1" 200 377 [Processing time 4 msec] "VMware vim-java 1.0"
    

     

  • Further /var/log/vmware/eam/eam_api.log and /var/log/vmware/eam/eam.log in vCenter can also be analyzed to check the EAM health and API status logs.

Environment

VMware NSX

Cause

Every 3 minutes, NSX checks for EAM status for all host-based service deployments on vCenter.

If NSX doesn't get a response from EAM Server, it raises an alarm.

Resolution

Maintenance window required for remediation? -- No

Start the ESX Agent Manager (EAM) service on vCenter. SSH into vCenter and invoke the command:
service-control --start vmware-eam

If EAM alarms are triggered due to no apparent EAM issues, follow resolution in the KB Unable to resolve EAM Status Down alarm in NSX-T

Note: May also have to restart the Proton service on the NSX manager to be able to resolve it.

Additional Information

This alarm could also be indicative of communication issues between vCenter and the NSX Manager(s), such as DNS forward and reverse lookups for the NSX Managers and Cluster VIP.  See Cannot edit Compute Manager in NSX UI - error "FQDNs are not configured for nodes IPs [#.#.#.#]. (Error code: 90335)" for details.

Other KBs with known issues related to ESX Agent Manager (EAM):

EAM service down Alarm is generated on NSX with multiple VCs registered

NSX Manager reports "EAM Status Down" Alarm comes up and gets resolved itself after few minutes