Cannot edit Compute Manager in NSX UI - error "FQDNs are not configured for nodes IPs [#.#.#.#]. (Error code: 90335)"
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Cannot edit Compute Manager in NSX UI - error "FQDNs are not configured for nodes IPs [#.#.#.#]. (Error code: 90335)"

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Article ID: 378663

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Updated On:

Products

VMware NSX

Issue/Introduction

  • When updating compute manager settings (i.e. updating thumbprint after a vCenter certificate change, updating credentials) or adding a compute manager, the following error prevents the connection:
    FQDNs are not configured for nodes IPs [<IP-Address>,<IP-Address>,<IP-Address>,<IP-Address>,]. (Error code: 90335)
  • The following error can be found in /var/log/proton/nsxapi.log:
     ERROR [c.v.v.c.n.s.c.c.ComplexHelpers,pool-2-thread-2] Exception occurred during NSX API invocation
    java.util.concurrent.ExecutionException: com.vmware.vapi.std.errors.InvalidRequest: InvalidRequest (com.vmware.vapi.std.errors.invalid_request) => {
      messages = [],
      data = struct => {error_message=FQDNs are not configured for nodes IPs [<IP-Address>,<IP-Address>, <IP-Address>, <IP-Address>]., httpStatus=BAD_REQUEST, error_code=90335, module_name=inventory-mgmt},
      errorType = INVALID_REQUEST
    }

Cause

The issue is caused due to reverse DNS entries not being configured on the relevant DNS server.

Resolution

NSX requires forward and reverse DNS entries for any of the following scenarios:

  • Starting with NSX 4.1 and later versions, in a dual stack environment (that is, both IPv4 and IPv6 have been configured).
  • Use cases where "publish_fqdns": true.
  • NSX Manager that uses CA-signed certificates.
  • NSX Manager with Multisite deployments. (It is optional for all other deployment types.) See Multisite Deployment of NSX in the NSX Administration Guide.

Additional Information

Configure NSX Manager for Access by DNS Server

Troubleshooting Steps:

  • Access each appliances via SSH as the root user.
  • Use the dig -x <IP_Address> command to check for existing reverse DNS (PTR) records for all NSX Manager node IPs and the Cluster VIP.
  • If entries are missing or incorrect, have the DNS administrator create both Forward (A) and Reverse (PTR) records.
  • Once DNS propagation is complete, return to the NSX Manager UI under System > Fabric > Compute Managers and retry the update.

Check with IP addresses of the NSX managers along with the VIP address. The IP address(es) mentioned in the error are the ones to investigate.