Troubleshooting virtual machine power on task hangs
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Troubleshooting virtual machine power on task hangs

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Article ID: 342633

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi VMware vCenter Server 6.0 VMware vCenter Server 7.0 VMware vSphere ESXi 6.0 VMware vSphere ESXi 7.0

Issue/Introduction

This article provides steps to troubleshoot a virtual machine (VM) that hangs when powering on.

Symptoms:
  • When powering on a virtual machine (VM), the power-on task does not complete and fails with one of the following error messages.
    • Another task is already in progress
    • Cannot complete operation due to concurrent modification by another operation.

  • VM options may appear greyed out.

Environment

  • VMware vSphere ESXi 7.x
  • VMware vSphere ESXi 8.x

Cause

This issue can be caused by:
  • ESXi OS problems
  • ESXi/vCenter OS is waiting for the administrator's answer to the question
  • Incompatible ESXi CPU for snapshot
  • Pending tasks
  • Storage array/datastore problems
  • VM configuration problems
  • VM guest OS incompatibility with ESXi host
  • vCenter OS problems

Resolution

Troubleshooting power on task hangs

  1. Wait at least 10 minutes for the task to fail.
  2. Look for any other relevant errors/warnings in the vCenter or ESXi host UI. If there are any, see Failed to power on virtual machine
  3. Find out if another task is still in progress. See Collecting information about tasks in VMware ESXi
    • Important: Do not cancel snapshot consolidation tasks. Doing so has a high chance of corrupting the VM's virtual disks.
    • If VM is running a task is not snapshot consolidation, you can attempt to cancel it.
    • If it won't cancel, power off the VM. If possible, power it off through the guest OS interface in an SSH or RDP session. If not, power it off in the vCenter UI. If won't power off in the vCenter UI, try to do so in the ESXi UI.
    • IF the VM won't power off, kill the VM processes per Unable to Power off a Virtual Machine in an ESXi host
  4. If no tasks are found, then please look at the vmware log for the VM for more information. The log file is found in: vmfs/volumes/<virtual machine datastore path>/vmware.log. Look for: 
  5. If you try to access the vmware.log and get I/O errors, then:
    • Troubleshoot for datastore/array problems, or
    • Restore or rebuild the VM to a healthier datastore.
  6. If you find no other issues, migrate the VM to another host and boot it from there.
  7. If VM won't migrate, kill VM processes per Unable to Power off a Virtual Machine in an ESXi host
  8. If the problem persists:
    1. Right-click the VM object in the vCenter or ESXi UI, select "Edit settings"
    2. Create a new VM that copies all of the VM's settings
    3. Attach the old VM's virtual disks to the new VM and see if it will boot.

Additional Information

For pending snapshot consolidation tasks, refer to the articles below.
 

Impact/Risks:
Performing the steps in this article can cause the following:
  • The affected VM is to be Unavailable.
  • The ESXi host will become unavailable when restarting ESXi management agents; any running tasks should be completed prior to running this.
  • Rebooting or restarting vCenter services can temporarily halt tasks that depend on vCenter Server, for example, backups and VM deployment.