Virtual Machine power-on failed with 'not Compatible with any Host'
search cancel

Virtual Machine power-on failed with 'not Compatible with any Host'

book

Article ID: 320852

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The VM power-on task fails with the error: "Virtual Machine not Compatible with any Host." 
  • DRS does not list the expected host which have sufficient resources for this vm power-on.
  • Following error messages found in vCenter /var/log/vmware/vpxd/drmdump/domain-c######/Plmt.log

    AntiAffinityRule 3 vm-## vm-## vm-##

Environment

VMware vCenter Server 8.x

Cause

'DRS Anti-Affinity Rules' constraint configured several virtual machines to be placed on the same host.

Resolution

  1. Verify 'DRS Anti-Affinity Rules':
    1. Navigate to the cluster in the vSphere Client.
    2. Select Configure > Configuration > VM/Host Rules.
    3. Identify any anti-affinity rules associated with the affected VM.
    4. Note the other VMs within the rule set. If all candidates are running, the rule prevents placement.
  2. Migrate VMs out of target host to match anti-affinity rules.