SRM or VR is unable to connect to vCenter after PSC is converged to Embedded PSC or vCenter SSL changed
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SRM or VR is unable to connect to vCenter after PSC is converged to Embedded PSC or vCenter SSL changed

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Article ID: 339651

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Background:

Announced in November 2018, the External Platform Services Controller (PSC) is being deprecated. Previously, many customers have deployed the External PSC to take advantage of features such as Enhanced Linked Mode (ELM) or PSC HA. With the removal of the External PSC, VMware has provided a Converge Tool to be able to migrate from an External Deployment to an Embedded deployment. The Converge Tool does require you to be on vSphere 6.5 Update 2d or greater or vSphere 6.7 Update 1 or greater and be running the vCenter Server Appliance (VCSA).

Understanding the vCenter Server Converge Tool

 

Before proceeding with the convergence ensure to have a screenshot of the SRM/VR configuration and an export of the configuration with the export import tool.


Symptoms:

  • PSC Convergence has been done, and attempts have been done to run Modify/Install on SRM Windows OR Reconfigure on SRM Appliance

  • Error 'null' appears on the SRM UI or it just fails to load

  • Site Recovery Manager and vSphere Replication services may crash eventually after starting up.
              -You may get an invalid thumbprint error when attempting to repair site connections or may receive an SDK timeout.
              -Reconfigure or Modify/Install fails.



Environment

VMware vSphere Replication 8.x
VMware vSphere Replication 9.x

Cause

  • This is due to stale entries of external PSC of source and target site still present in the database and needs to be updated.

  • SRM unable to pair sites due to VMDIR mismatch.

  • PSCs rolled back to different points in time.

  • Network connection loss between sites.

  • PSC Replication status failure.

Resolution

  • Check replication status of vCenter has no changes behind and has an updated status.
    psc1: ~ # /usr/lib/vmware-vmdir/bin/vdcrepadmin -f showpartnerstatus -h localhost -u administrator. If replication status is not matching on both vCenter Servers in linked mode, please log a new ticket with the vCenter Server as the support product.   
  • Continue to keep SRM ticket open until SRM is fully operational. 
  • Snapshot and backup all nodes SRM /VR /VC and backup the database of SRM. 
  • Run lsdoctor -l to check SSL certs on PSC and lsdoctor -t to run fix. Using the 'lsdoctor' Tool
  • Ensure vCenter certificate on port 5480 matches the vCenter certificate on port 443. refer article: VAMI does not display the new certificate after changing vCenter Server Appliance 6.x certificates
  • Modify install SRM installed on Windows or Reconfigure using the VAMI for SRM/VR Appliances
  • Reconnect site pairings. 

If the above steps do not resolve the issue, please raise a Broadcom Support Ticket

 

Additional Information

Impact/Risks:

May require a complete reinstall of SRM / VR environment or may lead to long downtime resolving the registration issues.