Unable to interact with vCenter Server objects using vSphere Web Client
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Unable to interact with vCenter Server objects using vSphere Web Client

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Article ID: 335934

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When selecting any of the tabs of any object displayed in vSphere Web Client, you see an error similar to:

    The connection to vCenter Server "###########" has been lost.

Environment

VMware vCenter Server 5.5.x

Cause

This issue occurs when the ADAM database corrupts.

Resolution

To resolve this issue, re-register vCenter Server to the Inventory Service.

To re-register vCenter Server to the Inventory Service:

Notes:

  • Ensure to take backup of your ADAM database, Inventory Service database, and vCenter Server database before proceeding with the steps.
  • vCenter Server must be installed in the default location using the default ports for vCenter Server, Inventory Service, and Single Sign On.
  • Ensure that you have the vCenter Server and ESXi host license keys documented before proceeding.
  1. Rebuild the ADAM database. For more information, see Cannot log in to vCenter Server after editing the ADAM database (1024329)

  2. Un-register vCenter Server from the Inventory Service by running this command:

    C:\Program Files\VMware\Infrastructure\VirtualCenter Server\isregtool> unregister-is.bat https://Inventory_Service_FQDN:10443 https://SSO_Service_FQDN:7444/lookupservice/sdk

  3. Register vCenter Server to the Inventory Service by running this command:

    C:\Program Files\VMware\Infrastructure\VirtualCenter Server\isregtool> register-is.bat https://VC_Service_FQDN:443/sdk https://Inventory_Service_FQDN:10443 https://SSO_Service_FQDN:7444/lookupservice/sdk

    Note: Wait for at least 10 minutes to allow the Inventory Service to synchronize all data from vCenter Server.

  4. Log in to the vSphere Web Client and attempt to interact with vCenter Server.

Additional Information