VC upgrade failed from 7.0.3 to 8.x in VCF 5.x
search cancel

VC upgrade failed from 7.0.3 to 8.x in VCF 5.x

book

Article ID: 327197

calendar_today

Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:

  • vCenter upgrade failing with error "VCSA_INSTALL_FAILED". In VCF 5.0, VCSA is failing to start its services.
  • First boot logs reports below errors: /var/log/vmware/applmgmt/firstboot/firstboot.json:

{
  "progress": 50,
  "progress_message": {
    "id": "install.ciscommon.component.starting",
    "translatable": "Starting %(0)s...",
    "args": [
      "VMware vCenter Server"
    ],
    "localized": "Starting VMware vCenter Server..."
  },
  "status": "error"
  "info": []
  "warning": [],
  "question": null,
  "error": {
    "detail": 
      {
        "id": "install.vpxd.action.failed",
        "translatable": "VMware VirtualCenter failed %(0)s.",
        "args": [
          "firstboot"
        ],
        "localized": "VMware VirtualCenter failed firstboot."
      },
      {
        "id": "install.vpxd.db.upgrade.failed",
        "translatable": "Database in-place upgrade failed. Please see vcdb_inplace.err and vcdb_inplace.out for details.",
        "localized": "Database in-place upgrade failed. Please see vcdb_inplace.err and vcdb_inplace.out for details."
      }
    ],
    "componentKey": "vpxd",
    "problemId": "install.vpxd.action.failed",
    "resolution": {
      "id": "install.vpxd.action.failed.resolution"

Environment

VMware Cloud foundation 5.x

vCenter 7.x

vCenter 8.x

Cause

This issue occurs if there is any inconsistency in database (VCDB)

Resolution

This needs modification in the database. Please Contact Broadcom support