Logging in to vCenter Server through SSH fails with Access Denied error, set the default shell for the user to bash.
"Access Denied"

You may also experience the following:
https://VC_IP:5480) using same credentials is successful.Invalid Shell/var/log/messages.log file, similar entries similar are seen:YYYY-MM-DDTHH:MM:SS vc sshd[23037]: User root not allowed because shell /bin/bosh does not existThis issue occurs when the default shell for a user is set to an invalid shell.
Follow these steps to verify if the issue is caused by an invalid shell configuration:
reboot the VCSAPress 'e' as soon as the Photon OS splash screen appears to enter edit mode.Linux.rw init=/bin/bash to the end of the line.F10 to continue the boot process.mount -o remount,rw /cat /etc/passwdFor example:...root:x:0:0:root:/root:/bin/applianceshroot:x:0:0:root:/root:/bin/appliancesh. If this entry does not contain /root:/bin/appliancesh review the /root/.bash_history file to see if an invalid shell was set with this command:less /root/.bash_history
For example:#1468577177chsh -s "/bin/bosh" root
Note: In the example above the root user has incorrectly set the shell to "/bin/bosh". The line above is the timestamp of this event in epoch format.
To enter the GRUB menu, reboot the VCSA and press 'e' as soon as the Photon OS splash screen appearsAppend rw init=/bin/bash to the end of that lineF10 to continue the boot processchsh -s /bin/bash root cat /etc/passwd Post verifying, VCSA can be rebooted.