vSAN Health Service – Physical Disk Health – Component Metadata Health
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vSAN Health Service – Physical Disk Health – Component Metadata Health

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Article ID: 327060

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Updated On:

Products

VMware VMware vSAN

Issue/Introduction

This article explains the Physical Disk Health - Component Metadata Health check in the vSAN Health Service and provides details on why it might report an error.

Q: What does the Physical Disk Health – Component Metadata Health check do?
A: This health check verifies the integrity of the component metadata on a disk.


Symptoms:
vSAN cluster showing Component Metadata Health test failed in red state for one or more disks in one or more nodes.

Environment

VMware vSAN

Cause

Q: What does it mean when it is in an error state?
A: If this health status from this check is not green (OK), vSAN has encountered an issue with an individual component.

This error will not cause vSAN to decommission the disk on which the component resides. But in rare cases where bad metadata is detected, the problem might lead to additional issues with the object that contains the component. In particular, if the number of prepared I/O equals 255, or if the number of committed I/O​ is larger than 10,000, the Component metadata health check returns an error (this particular criteria was removed in vSphere 6.0 patch 03 and later releases).

Resolution

Q: How does one troubleshoot and fix the error state?
A: This error might be caused by faulty drives, a faulty controller, or a misbehaving device driver, but it might be intermittent and originate from the vSAN software. The best approach would be to isolate each storage component from the software and hardware layer, validating from the vendor's GUI if the information matches in the virtual layer in the Web client.

The commit I/O larger than 10,000 failure might be intermittent (this particular criteria was removed in vSphere 6.0 patch 03 and later releases). But other test failures might require VMware Support.


Additional Information

For more information on collecting VMware vSAN logs, see Collecting vSAN support logs and uploading to VMware (2072796).

Additional resources: vSAN Health Service - Cluster Health - Advanced vSAN configuration in sync
vSAN Health Service - Network Health - Hosts disconnected from vCenter Server
vSAN Health Service - Network Health - Unexpected vSAN cluster members
vSAN Health Service - Network Health - vSAN Cluster Partition
vSAN Health Service - Network Health – Hosts with vSAN disabled
vSAN Health Service - Network Health - All hosts have a vSAN vmknic configured
vSAN Health Service - Network Health - Hosts small ping test (connectivity check) and Hosts large ping test (MTU check)
vSAN Health Service - Network Health - Hosts with connectivity issues
vSAN Health Service - Data Health – vSAN Object Health
vSAN Health Service - Physical Disk Health - Overall Disk Health
vSAN Health Service - Limits Health – Current Cluster Situation
vSAN Health Service - Limits Health – After one additional host failure
vSAN Health Service - Physical Disk Health - Disk Capacity
vSAN Health Service - Physical Disk Health – Congestion
vSAN Health Service - Physical Disk Health – Memory pools
vSAN Health Service - vSAN HCL Health - Controller Release Support
vSAN Health Service – vSAN HCL Health – Controller Driver
vSAN Health Service - vSAN HCL Health – vSAN HCL DB up-to-date
vSAN Health Service - vSAN HCL Health – SCSI Controller on vSAN HCL
vSAN Health Service - Cluster Health – CLOMD liveness check
vSAN Health Check Information