NSX-T Telemetry for On-Prem/Local Manager does not load in Global Manager UI
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NSX-T Telemetry for On-Prem/Local Manager does not load in Global Manager UI

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Article ID: 326360

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Updated On:

Products

VMware NSX

Issue/Introduction

  • The issue affects On-Prem Managers in Local Managers in a Federation deployment.
  • An upgrade to version 4.1.1 has recently been completed.
  • A restore from backup was performed on the On-Prem/Local Manager prior to upgrading to 4.1.1
  • The following logging is present on the On-Prem/Local Managers

    /var/log/proxy/keystore.log

    [TIMESTAMP] Envoy: Envoy cert password file already exists. (false)
    [TIMESTAMP] Envoy: Using password 8Gyc############
    [TIMESTAMP] Dummy certificate extraction finished with code 1
    [TIMESTAMP] Cacerts truststore creation finished with code 1


    /var/log/syslog
    [TIMESTAMP]  envoy 83297 - - keytool error: java.io.IOException: Keystore was tampered with, or password was incorrect
    [TIMESTAMP]  envoy 83535 - - keytool error: java.io.FileNotFoundException: vamlogin.crt (No such file or directory)
    [TIMESTAMP]  envoy 83622 - - chown: cannot access '/home/secureall/secureall/.store/.cacerts_store': No such file or directory

Environment

VMware NSX 4.x
VMware NSX-T Data Center 3.x

Cause

When upgrading from a version prior to 4.1.1, a new trust store called ".cacerts_store" should be created. However, this process does not occur if the system has undergone a restore in the past. As a result, metrics and flow data are not sent from On-Prem Managers to Local Managers to Global Managers.

Resolution

This issue is resolved in VMware NSX 4.1.2, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.




Additional Information