NSX-T Global Manager error "Location X is not reachable, Networking entities needs to be reviewed"
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NSX-T Global Manager error "Location X is not reachable, Networking entities needs to be reviewed"

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Article ID: 324211

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Updated On:

Products

VMware NSX

Issue/Introduction

  • On the Global Manager under Configuration -> Location Manager, a red banner is displayed "Location X is not reachable, Networking entities needs to be reviewed"
  • On the Local Manager under Configuration -> Location, the Global Manager connection is displayed as green and Active.
  • The environment is functioning as normal with no known issues.

Environment

VMware NSX-T Data Center 3.x

Cause

This UI error is a false positive. The incorrect status occurs due to a mismatch between the persisted and in-memory connection values.

Resolution

This issue is resolved in VMware NSX 3.2, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.



Workaround:
To workaround this issue and clear the error banner, a restart of the Async Replicator service on the Global Manager is required. The restart must be perform on the Global Manager which is the leader of the AR service.

  • To identify the AR Leader, on any Global Manager as admin user
#get cluster status verbose

Group Type: ASYNC_REPLICATOR
Group Status: STABLE

Members:
UUID FQDN IP STATUS
########-####-####-####-##########56 global1 10.#.#.# UP
########-####-####-####-##########48 global2 10.#.#.# UP
########-####-####-####-##########11 global3 10.#.#.# UP

Leaders:
SERVICE LEADER LEASE VERSION
site-manager ########-####-####-####-##########56 740
ar ########-####-####-####-##########56 737   <<<< AR Leader UUID

 

  • ssh as admin user to the Global Manager identified above
Restart the AR service: 

#service async-replicator-service restart


Alternatively, a reboot of the GM appliance can be performed.

Attachments

global-manager get_app