VMs missing from NSX inventory after vMotion
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VMs missing from NSX inventory after vMotion

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Article ID: 323684

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Updated On:

Products

VMware NSX

Issue/Introduction

  • VMs falling out of NSX inventory intermittently, or VMs are missing from NSX inventory on certain hosts after a vMotion.
  • DFW rules will not be applied to VMs that are vMotioned to the affected host.
  • New VMs cannot be deployed on the affected host.
  • Tags will be permanently removed, and the user/customer has to manually add the Tags to the VM.
  • On the ESXi host in /var/log/nsx-syslog*, a log message with "Size of chunk message being sent to MP" or "Sending HEARTBEAT" should be seen at least once every 30 minutes, if not present, it indicates a match to this known issue


    <Date>T<Time>Z nsx-opsagent[2875060]: NSX 2875060 - [nsx@6876 comp="nsx-esx" subcomp="opsagent" s2comp="nsxda" tid="2875583" level="INFO"] Size of chunk message being sent to MP [5]

 

Environment

VMware NSX-T

Cause

Due to excessive DFW logging nsx-opsagent goes into an error state where it cannot send messages from the host to Manager

Resolution

This issue is resolved in VMware NSX 3.2.4 and 4.2.0, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.


Workaround:

If this condition is experienced on an ESXi host, an nsx-opsagent restart will solve the issue but it may return at a later time

#/etc/init.d/nsx-opsagent restart