NSX Fabric Status: Aggregate Count Widget LabelValueConfiguration_HostCommunicationChannelStatus has an invalid number null
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NSX Fabric Status: Aggregate Count Widget LabelValueConfiguration_HostCommunicationChannelStatus has an invalid number null

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Article ID: 322559

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Updated On: 02-03-2025

Products

VMware NSX for vSphere

Issue/Introduction

Symptoms:

  • In the NSX vSphere plugin, the Fabric status contains entries similar to:

    Failed to get data for 'Host Preparation Status, Host Communication Channel Status' : Aggregate Count Widget LabelValueConfiguration_HostCommunicationChannelStatus has an invalid number null. Only numbers are allowed as fields for aggregate_count sub-type.

  • In the NSX manager logs, you see entries similar to:

    Note: Error in NSX manager logs indicates that the error is associated with host: host-#### > this will be the offending host.

    2018-08-29 10:44:46.093 GMT-00:00 ERROR HostStatusServiceInitThread FabricDeployerImpl:471 - - [nsxv@6876 comp="nsx-manager" subcomp="manager"] Resource host-#### not found in inventory.

    vsm.logs2018-08-29 12:21:39.813 GMT-00:00 INFO http-nio-127.0.0.1-7441-exec-4 GenericDashboardServiceImpl:589 - Finished calculating the list of entitled widgets. [{class:LabelValueConfiguration id:LabelValueConfiguration_HostCommunicationChannelStatus}, {class:GridConfiguration id:GridConfiguration_hccsGrid}, {class:LabelValueConfiguration id:LabelValueConfiguration_ShortLivedSettings}, {class:LabelValueConfiguration id:LabelValueConfiguration_SystemScale}]
     
    2018-08-29 12:21:46.097 GMT-00:00 WARN http-nio-127.0.0.1-7441-exec-10 RemoteInvocationTraceInterceptor:88 - Processing of VsmHttpInvokerServiceExporter remote call resulted in fatal exception: com.vmware.vshield.vsm.dashboard.facade.SystemDashboardFacade.getReportsData
    InvalidArgumentException: core-services:1355316:Aggregate Count Widget LabelValueConfiguration_HostCommunicationChannelStatus has an invalid number null. Only numbers are allowed as fields for aggregate_count sub-type.
    at com.vmware.vshield.vsm.dashboard.converter.widgets.legacy.AggregateCountConverter.convertToLegacy(AggregateCountConverter.java:40)
    at com.vmware.vshield.vsm.dashboard.util.DashboardUtilsImpl.convertToLegacy(DashboardUtilsImpl.java:122)
    at com.vmware.vshield.vsm.dashboard.facade.SystemDashboardFacadeImpl.getReportsData(SystemDashboardFacadeImpl.java:66)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:333)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:190)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:157)
    at org.springframework.remoting.support.RemoteInvocationTraceInterceptor.invoke(RemoteInvocationTraceInterceptor.java:78)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
    at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:213)
    at com.sun.proxy.$Proxy552.getReportsData(Unknown Source)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)


    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.



Environment

VMware NSX for vSphere 6.4.x

Cause

This issue occurs when under some circumstances, one of the internal tables becomes out of sync with the inventory as it no longer exist in the vCenter Server.

Resolution

To resolve this issue, file a support request with Broadcom Support and quote this Knowledge Base article ID (322559) in the problem description. For more information, see  

Broadcom case management frequently asked questions

https://knowledge.broadcom.com/external/article?articleId=144456
 
Note: Customer must have purchased Extended Support for NSX-V, as it is EOL, to receive support for NSX-V. For more information please reference End of Availability - VMware NSX Data Center for vSphere