NSX UI displays alarms indicating 'OSPF Neighbors Went Down'
search cancel

NSX UI displays alarms indicating 'OSPF Neighbors Went Down'

book

Article ID: 322464

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • You are running NSX-T 3.1.1 or above with OSPF routing configured.
  • NSX UI displays alarms indicating 'OSPF Neighbors Went Down'.
  • If you resolve the alarms, they appear again.
  • These alarms are not related to changes made on the environment ie. re-election or configuration change on OSFP routers outside of NSX-T.
  • There is no dataplane impact..



Environment

VMware NSX-T Data Center

Cause

Due to the nature of OSPF, as neighbors are not statically added, alarms can be generated when configuration changes occur outside of NSX-T control, such as configuration changes or re-election.
Under normal circumstances, when these alarms are triggered and it is known they are due to the above, the alarms can be resolved and should not re-appear again until a change occurs again.
In certain cases, the alarms may not be resolved and are persisted internally.

Resolution

This issue is resolved in VMware NSX 4.0>, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.



Workaround
As a workaround to clear these alarms, restart the RCPM (Routing Control Plane Manager) service on the relevant edge node(s):
  • Login to the Edge nodes using root credentials and run:
    service nsx-edge-rcpm restart

NB:  Our recommendation is to perform this workaround during a scheduled maintenance window as a short dataplane impact is expected.