The /storage/log folder becomes 100% full when exporting vCenter log bundles
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The /storage/log folder becomes 100% full when exporting vCenter log bundles

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Article ID: 318835

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Updated On:

Products

VMware vCenter Server 6.0 VMware vCenter Server 7.0 VMware vCenter Server 8.0

Issue/Introduction

Symptoms:

  • The "/storage/log" partition becomes 100% full while trying to generate a vCenter Appliance log bundle
  • vCenter UI may not be accessible
  • There may be errors such as:  
    • 503 Service Unavailable
    • no healthy upstream

Validate by running following on the vCenter. 

      # df -h 

           The output is be similar to the following :

     Filesystem             Size  Used  Avail Use%  Mounted on
     /dev/mapper/log_vg-log 9.9G  9.9G  0G    100%  /storage/log

  • vCenter management activities may be paused, such as vMotion of guest machines

Environment

VMware vCenter Server 6.x
VMware vCenter Server 7.x
VMware vCenter Server 8.x


Cause

There are support log bundles or other files in the vCenter log directory which are consuming space, thus filling up the /storage/log partition.

Resolution

 
 
IMPORTANT! Take an offline (powered off) snapshot the vCenter server before any data removal procedures. See "Snapshot Best practices for vCenter Server Virtual Machines" and "VMware vCenter in Enhanced Linked Mode pre-changes snapshot (online or offline) best practice".

1. Search for log bundles. Log bundles by default will be named similar to "vc-support-<vc_name>-<date&time>.tgz"

# find / -name *.tgz

2. Navigate to the relevant directory:

# cd /storage/log

3. Delete the log bundles: 

rm <logbundlename>.tgz

4. Restart vCenter services:

service-control --stop --all && service-control --start --all

Additional Information