NCP Plugin Down Alarm is shown in NSX-T and cannot be cleared.
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NCP Plugin Down Alarm is shown in NSX-T and cannot be cleared.

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Article ID: 318317

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Updated On:

Products

VMware NSX

Issue/Introduction

  • The alarm "NCP Plugin Down " with summary of  "Manager Node has detected the NCP is down or unhealthy" is shown in the dashboard.
  • Resolving the alarm via UI or API does not work: the alarm is triggered again.
  • The API call GET/api/v1/systemhealth/containter-cluster/ncp/status returns empty result.
  • Tanzu was removed in vCenter by deleting the containers cluster nodes instead of running the NCP clean up script first and the Alarm appeared after the nodes removal.
  • The related containers cluster does not exist anymore.

Environment

VMware NSX-T Data Center 3.x
VMware NSX-T Data Center

Cause

This behavior is caused by the current NCP alarm design by which the currently connected NSX-T Manager node handles the alarms.

Once the NCP alarm is generated from one NSX-T Manager node and NCP changes to report its status to another NSX-T Manager node, the alarm on the previous NSX-T Manager node can't be resolved anymore.

Resolution

This issue is resolved in VMware NSX 3.2.0, available at Broadcom downloads.

If you are having difficulty finding and download software, please review the Download Broadcom products and software KB.


Workaround:

Restart the proton service on the NSX-T Manager node reporting the alarm.