HTML5 NSX 6.4.4 plugin missing after NSX upgrade. FLEX Flash plugin is working correctly.
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HTML5 NSX 6.4.4 plugin missing after NSX upgrade. FLEX Flash plugin is working correctly.

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Article ID: 318253

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Updated On: 02-03-2025

Products

VMware NSX for vSphere

Issue/Introduction

After upgrade to NSX 6.4.4 the vShiled (FLEX Flash) Plugin is updated correctly and showing the new version 6.4.4 while the HTML5 UI version is still the old one.

Environment

VMware NSX for vSphere 6.4.x

Cause

The issue is that it the H5 plugin is attempted to be upgraded instead of created and when this fails, there is no attempt for creating it.

Resolution

This issue is resolved in VMware NSX for vSphere 6.4.5 available at Broadcom Downloads.
If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

Workaround:

Resolution steps:

When H5 plugin ("com.vmware.nsx.ui.h5") is not getting registered in the MOB. But we can see "com.vmware.vShieldManager" plugin in the MOB.

(Note: We should take snapshot of both VC and VSM before performing below steps. Confirm If we have enough space available for snapshot)

A. Backup and Clear the downloaded/copied plugins on VC:
 1. Logout from all web UI sessions of vSphere Web Client
 2. STOP servicess "vsphere-client", "vsphere-ui"
	service-control --stop vsphere-client;
	service-control --stop vsphere-ui;
 3. BACKUP all plugins from "vsphere-client" and "vsphere-ui" i.e. backup folder "vsphere-client-serenity"
  3.1 Take backup of folder "vsphere-client-serenity" to some other location outside of "/etc/vmware" say "/ect/temp" for,
  3.2 "/etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity/"
  3.3 "/etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/"
 4. REMOVE all plugins from "vsphere-client-serenity" ("com.vmware.vShieldManager" and "com.vmware.nsx.ui.h5" from the VC)
  4. Clear contents of folder "vsphere-client-serenity" from the VC for below paths:
  4.1 "/etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity/"
  4.2 "/etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/"

B. Unregister the "com.vmware.vShieldManager" plugin:
 1. Log in to the Managed Object Browser of the vSphere Web Client at https://<<vsphere_address>>/mob with Administrator credentials.
    1.1 Note: Replace "<<vsphere_address>>" with the IP address or FQDN of the vSphere Web Client.
 2. Navigate to Content > ExtensionManager (e.g. https://<<vsphere_address>>/mob/?moid=ExtensionManager)
 3. In the properties list, click (more…) to expand the list of values
 4. Confirm that,
    4.1 "com.vmware.vShieldManager" is listed
	4.2 "com.vmware.nsx.ui.h5" is not listed
	    Here assumption is, we should only see "com.vmware.vShieldManager", and we should not see "com.vmware.nsx.ui.h5" as we have already unregistered "com.vmware.nsx.ui.h5".
 5. Click "UnregisterExtension" at the bottom of the page
    5.1 Enter the plugin name to unregister (e.g. "com.vmware.vShieldManager")
	5.2 Click Invoke Method
	5.3 A VOID message appears, confirming that the extension is successfully unregistered
	5.4 If we found that "com.vmware.nsx.ui.h5" is listed in step 4, then we should unregister "com.vmware.nsx.ui.h5" as well
 6. START vsphere-client, vsphere-ui service on the VC (Confirm that we have stopped it in step A.2)
		service-control --start vsphere-client;
		service-control --start vsphere-ui;

C. Open putty tail NSX logs and Virgo log:
 1. Virgo (web client logs)
    tail -f /var/log/vmware/vsphere-client/logs/vsphere_client_virgo.log
 2. VSM (NSX Manager logs)
    tail -f /home/secureall/secureall/logs/vsm.log


D. Re register NSX Manager with VC and Unregister-Register LookupService:
 1. Login to NSX Manager Virtual Appliance Management UI with admin credentials
 2. Click on "Manage vCenter Registration"
 3. Re register NSX Manager with VC on NSX manager (with Administrator@vsphere.local credentials)
 4. Re configure the Lookup Service on NSX manager (If already configured, else do not do any thing)
    4.1 First "Unconfigure" the lookup service by clicking "Unconfigure" button
	4.2 Configure Lokkup service by clicking "Edit"

D. Re register NSX Manager with VC:
 1. Login to NSX Manager Virtual Appliance Management UI with admin credentials
 2. Click on "Manage vCenter Registration"
 3. Note down the Lookup Service details like (Lookup Service Host, Lookup Service Port, SSO Administrator User Name), we will require these while reconfiguting lookup service 
 4. Unconfigure the Lookup Service on NSX manager 
 5. Re register NSX Manager with VC on NSX manager (with Administrator@vsphere.local credentials)
 6. Configure the lookup service

	
E. Clear the browser cache, check MOB
 1. Log in to the Managed Object Browser of the vSphere Web Client at https://<<vsphere_address>>/mob with Administrator credentials.
 2. Navigate to Content > ExtensionManager (e.g. https://<<vsphere_address>>/mob/?moid=ExtensionManager)
 3. Confirm that,
    3.1 "com.vmware.vShieldManager" is listed
	3.2 "com.vmware.nsx.ui.h5" is listed
 4. Relogin to web UI (vmware vSphere web client), UI should get loaded for both FLEX/H% plugins