Skyline Collector Status: ‘Failed to Collect Data’
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Skyline Collector Status: ‘Failed to Collect Data’

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Article ID: 317539

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Updated On:

Products

VMware

Issue/Introduction

Message on Skyline Advisor: “Data Collection is unsuccessful for all configured product endpoints.”

Resolution

Cause:

The Skyline Collector is not collecting data from at least one of the configured products. This issue is due to one of the following reasons:
 

  1. Unable to communicate with the endpoint on port 443
  2. Endpoint password has expired
  3. Endpoint configuration is changed or certificate was updated
  4. Required permissions are not assigned


Resolution:
 

  1. Test communication status for endpoints
    1. Using the vSphere Client, open the remote console of the Skyline Collector virtual appliance.
    2. Log in to the console of the Skyline Collector virtual appliance with user 'root'.
    3. Execute the command:
      ping endpoint (vCenter, Horizon, vROps, NSX, SDDC FQDN/IP Address)
      ping vcenter.vsphere.local
      Ping 192.168.1.50 (replace the IP address with the current vCenter or any other endpoint IP address)
      Curl -v
      https://endpoint:443 (vCenter, Horizon, vROps, NSX, SDDC))

       
  2. Follow the steps below to check if the Endpoint password has expired, or if the configuration is changed, or the certificate was updated.
    1. Login to the Skyline Collector UI by going to https://Skyline_VM_IP Address
    2. Use the admin user credentials to log in
    3. Click on the ‘Configuration’ tab
    4. Click ‘edit’ next to the endpoint (vCenter, Horizon, vROps, NSX, SDDC) for which you are seeing an issue reported with Red exclamation
    5. Update the correct credentials
      • Note: If the user used has a password policy to expire the password, request you to use an AD User and disable password expire for that User
    1. Save and update the certificate thumbprint
      • If updating the endpoint credentials results in an error reporting the connectivity test to the endpoint has failed "Endpoint test failed. ->null", reboot the end-point system (SDDC manager) and verify the end-point connectivity issue is resolved after the system has been rebooted.
    •  
  1. If the required permissions are not updated, follow the steps mentioned in KB319321 - VMware Skyline Log Assist Rights.

Additional Information