SNMP Discovery error
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SNMP Discovery error

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Article ID: 315845

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

CICSO Nexus 7k devices that are showing this error during the Smarts IP discovery process: 

Error: SWFE-E-EGETNEXT-While getting next of OID .1.3.6.1.2.1.15.3.1.5

Environment

10.x

Cause

When Smarts performs a discovery poll using SNMP, the device SNMP Agent provides a list of OIDs in the response to Get Next Request.  

The SNMP Agent is telling Smarts this OID is available.  OID .1.3.6.1.2.1.15.3.1.5  

Smarts expects the SNMP Agent accordingly to the established RFCs. If the data for the OID requested, is not available, The RFC states the SNMP Agent should respond with one of the following:

NOSUCHOBJECT
NOSUCHNAME
NOSUCHINSTANCE


Resolution

The solution is to contact the vendor and let them know there is a bug in the SNMP Agent.

You can use the following KB to roll the IP Domain log and enable the setTrace function for the specific device in question.

Enable/disable SNMP tracing/debug on a single device in Smarts IP?

This will enable you to see the SNMP Agent responses in the IP domain log file that Smarts is receiving from the device. Avoid doing this when there is a discovery in progress for cleaner log output.

In addition, you can run a tcp dump filtered for the snmp traffic between the IP server and the specific device and provide this data to the vendor.

As mentioned in the cause Smarts expects the SNMP Agent to respond with the details of the requested oid or the following:

NOSUCHOBJECT
NOSUCHNAME
NOSUCHINSTANCE



Workaround:
There is no other workaround for this issue if you want to discover the device via SNMP.

Additional Information

Impact/Risks:
Discovery error generated and device will not be discovered.