Disks claimed for a vSAN Datastore are not visible in the Disk Management tab in vCenter but can be observed via the ESXi host command line.
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Disks claimed for a vSAN Datastore are not visible in the Disk Management tab in vCenter but can be observed via the ESXi host command line.

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Article ID: 315543

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Updated On:

Products

VMware vSAN

Issue/Introduction

Isolate any vSAN layer issues and confirm if this is a cosmetic display issue whereby the vCenter Web Client interface is unable to recognize the disks used in the vSAN layer.
 
Impact/Risks:

There is no impact reported, this is a mere display issue that does not affect vSAN operations. 

Should there be a need to add/remove a disk/diskgroup before the vCenter can be upgraded, then this can be done via the command line as per the instructions in the following KB article:

How to manually remove and recreate a vSAN disk group using esxcli


Symptoms:
Disks claimed for a vSAN Datastore are not visible in the vCenter Web Client <vSAN Cluster> Configure>vSAN>Disk Management.

Disks can be observed via the command line by running any of the commands below:
esxcli vsan storage list |grep -i cmmds
   In CMMDS: true
   In CMMDS: true

vdq -iH
Mappings:
   DiskMapping[0]:
           SSD:  mpx.vmhba2:C0:T0:L0
            MD:  mpx.vmhba2:C0:T1:L0

vdq -iq
[
   {
      "Name"     : "mpx.vmhba2:C0:T1:L0",
      "VSANUUID" : "########-####-####-####-########adf8",
      "State"    : "In-use for VSAN",
      "Reason"   : "None",
      "IsSSD"    : "1",
"IsCapacityFlash": "1",
      "IsPDL"    : "0",
      "Size(MB)" : "16384",
   "FormatType" : "512n",
   },

   {
      "Name"     : "mpx.vmhba2:C0:T0:L0",
      "VSANUUID" : "########-####-####-####-########6d26",
      "State"    : "In-use for VSAN",
      "Reason"   : "None",
      "IsSSD"    : "1",
"IsCapacityFlash": "0",
      "IsPDL"    : "0",
      "Size(MB)" : "8192",
   "FormatType" : "512n",
   },

   {
      "Name"     : "mpx.vmhba0:C0:T0:L0",
      "VSANUUID" : "",
      "State"    : "Ineligible for use by VSAN",
      "Reason"   : "Has partitions",
      "IsSSD"    : "0",
"IsCapacityFlash": "0",
      "IsPDL"    : "0",
      "Size(MB)" : "8192",
   "FormatType" : "512n",
   },

]

Environment

VMware vSAN (All Versions)

Cause

vCenter is on an older build than that of the hosts. This leads to vCenter not being able to recognize the disks even though they are mounted and eligible for use by vSAN. You can confirm this by checking the build version number in the summary tab of the vCenter icon and in each ESXi in the vSAN cluster.

For more information regarding vCenter/ESXi version mismatch see KB:

vCenter version to ESXi version

You can also manually check the versions in the links below and validate the release date. The vCenter version should always be equal to or newer than the ESXi version.
Build numbers and versions of VMware vCenter Server
Build numbers and versions of VMware ESXi/ESX

 

Resolution

Upgrade vCenter to an equivalent or higher build than what the hosts are on. This will allow vCenter to recognize the vSAN disks and create/delete disk groups with them. At the end of the upgrade, the vCenter Server will need to be rebooted which will not have any impact on the vSAN layer however the only impact is that the vCenter Web Client interface will be unavailable until the vCenter Server comes back online.


Additional Information