Error: "Unable to connect to vCenter ..." when configuring replications due to a vCenter Server UUID mismatch in VMware Cloud Director
search cancel

Error: "Unable to connect to vCenter ..." when configuring replications due to a vCenter Server UUID mismatch in VMware Cloud Director

book

Article ID: 315168

calendar_today

Updated On:

Products

VMware Cloud Director VMware Live Recovery

Issue/Introduction

  • Configuring a new replication fails in VMware Cloud Director Availability (VCDA), and you see the error:

    Unable to connect to vCenter '########-####-####-####-########6c26'.

  • In the /opt/vmware/h4/cloud/log/cloud.log file on the Cloud Director Replication Management Appliance, you see an entry similar to:

    ERROR - [UI-########-####-####-####-########f2ba-0y-S2] [job-12] com.vmware.h4.jobengine.JobExecution     : Task ########-####-####-####-########1e01 (WorkflowInfo{type='start', resourceType='vappReplication', resourceId='C4VAPP-########-####-####-####-########75ca', isPrivate=false, resourceName='null'}) has failed

    com.vmware.h4.replicator.api.exceptions.FailedToAcquireVcConnection: Unable to connect to vCenter '########-####-####-####-########6c26'.

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

  • VMware Cloud Director Availability 4.x
  • VMware Cloud Director 10.x

Cause

This issue occurs on the destination site when the instance UUID of a resource vCenter Server in VMware Cloud Director (VCD) has changed, but Cloud Director is not aware of the vCenter UUID change or Cloud Director has an incorrect value saved for the vCenter UUID.

Resolution

To verify that you are experiencing this issue, compare the current vCenter instance UUIDs for each resource vCenter Server with the UUIDs stored by Cloud Director.

vCenter Server Appliance

  1. SSH to the vCenter Server Appliance and log in as root.
  2. Show the vCenter instance UUID with the command:

    grep instanceUuid /etc/vmware-vpx/instance.cfg

Cloud Director

  1. SSH to the primary Cloud Director cell and log in as root.
  2. Connect to the Cloud Director database:

    db

  3. List all of the resource vCenter Servers and their UUIDs:

    select name, url, uuid from virtual_center;

  4. Compare the values in the uuid column to the current instanceUuid values of the resource vCenter Servers.
  5. If there is a mismatch between the Cloud Director database and the vCenter Servers then you have confirmed you are experiencing this issue.

To resolve this issue contact Broadcom Support and note this Article ID (76301) in the problem description. For more information, see Creating and managing Broadcom support cases.

Additional Information