Error: "Unable to connect to vCenter ..." when configuring replications due to invalid SSO credentials being used by the Replicator Appliance
search cancel

Error: "Unable to connect to vCenter ..." when configuring replications due to invalid SSO credentials being used by the Replicator Appliance

book

Article ID: 315114

calendar_today

Updated On:

Products

VMware Cloud Director VMware Live Recovery

Issue/Introduction

  • Configuring a new replication in VMware Cloud Director Availability fails with a similar error:

    Unable to connect to vCenter "########-####-####-####-########ed5a".

  • In the /opt/vmware/h4/cloud/log/cloud.log file on the Cloud Director Replication Management Appliance, you see entries similar to:

    ERROR - [UI-########-####-####-####-########29ed-WI-IZ] [https-jsse-nio-8044-exec-7] c.v.h.c.c.error.ExceptionAdvisorBase : A POST request from __system[127.0.0.1] to /inventory/########-####-####-####-########ed5a/vms/vm-by-name failed.
    Caused by: com.vmware.vim.binding.vim.fault.InvalidLogin: Cannot complete login due to an incorrect user name or password.

    com.vmware.vim.binding.vim.fault.NotAuthenticated: The session is not authenticated.
    ...
    WARN - [UI-########-####-####-####-########d8f1-VD-rH] [https-jsse-nio-8043-exec-8] c.v.h.r.diagnostics.DiagnosticsService : Unable to connect to vc "########-####-####-####-########ed5a" with manager ########-####-####-####-########80a4's credentials.


  • In the System Health view of the Replicator Appliance, the Lookup Service connectivity shows as offline and you see an error similar to:

    Operation aborted due to an unexpected error

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware Cloud Director Availability 4.x

Cause

This issue can occur when the SSO credentials for the service user used in VMware Cloud Director Availability have expired or were altered on the vCenter Server level.

Resolution

To resolve this issue, renew the vCenter Server user credentials and repair the local Replicator Appliances to update the credentials used to connect to the vCenter Server.

  1. Renew the vCenter Server SSO user credentials.
  2. Navigate to the Cloud Director Replication Management Appliance in a browser on port 8441.
  3. Log in with root user credentials.
  4. In the left pane, click Replicator Services.
  5. Select a local Replicator Service and click Repair.
  6. Enter the Replicator password, SSO credentials, and click Apply.
  7. Repeat steps 5 and 6 for each local Replicator Service.

To push the updated Replicator Service configuration to paired sites, perform a re-pair of all sites:

Additional Information