Error message "Operation aborted due to an unexpected error" while authenticating the Replicator appliance with the vCenter Server in VMware Cloud Director Availability
book
Article ID: 315114
calendar_today
Updated On:
Products
VMware Cloud Director
Issue/Introduction
Symptoms:
Configuring a new replication in VMware Cloud Director Availability fails with a similar error:
Unable to connect to vCenter "2xxxx4-exxd-4xx8-bxxf-5xxxxxxxa"
In the System Monitoring view of the VMware Cloud Director Availability Replicator, the vCenter shows as offline and you see a similar error:
Operation aborted due to an unexpected error
In /opt/vmware/h4/cloud/log/cloud.log on the vApp Replication Manager, you see a similar entry:
2020-03-19 16:12:18.618 DEBUG - [3bxxxxf-dxxa-4xxc-8xx8-06xxxxxx1_Sf] [https-jsse-nio-8044-exec-8] c.v.h.m.services.DiagnosticsService : Received ping from replicator dcxxxf-xxx-xxxx-baxxxaf-afxxxxxxxx4 2020-03-19 16:12:31.574 ERROR - [UI__52x34-xe209-xxx-xx-9exxxxxxd_WI_IZ] [https-jsse-nio-8044-exec-7] c.v.h.c.c.error.ExceptionAdvisorBase : A POST request from __system[127.0.0.1] to /inventory/2exxxxe4-exxd-4xx8-bxxf-59f5xxxxxx79aa /vms/vm-by-name failed. Caused by: com.vmware.vim.binding.vim.fault.InvalidLogin: Cannot complete login due to an incorrect user name or password.
com.vmware.vim.binding.vim.fault.NotAuthenticated: The session is not authenticated.
2020-03-19 15:55:31.351 WARN - [UI__dxxx40-4xx3-4xx4-8xx0-fxxxx1_VD_rH] [https-jsse-nio-8043-exec-8] c.v.h.r.diagnostics.DiagnosticsService : Unable to connect to vc ""2xxxx4-exxd-4xx8-bxxf-5xxxxxxxa with manager 1xxxx5-8xx6-4xxd-8xx8-0axxxxxxxx4's credentials
The replicator shows offline status, in case there is a reboot done for the replicator applaince in the vCenter.
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
Environment
VMware Cloud Director Availability 4.x.x
Cause
This issue can occur when the SSO credentials for the service user used in VMware Cloud Director Availability expires on the vCenter Server level.
Resolution
To resolve this issue, renew the vCenter user credentials and repair the Replicators to update the credentials used to connect to the vCenter Server.
Renew the vCenter Server SSO user credentials.
Navigate to the Replication Manager Portal in a browser on port 8441 ( vCDA_FQDN_or_IP:8441).
Login with root user credentials.
In the left pane, click Replicators.
Select a local Replicator and click Repair.
Enter the Replicator password, SSO credentials, and click Apply.
Repeat steps 5 and 6 for each local Replicator.
To complete the Re-Trust establishment between the two sites, re-pair the two sites.
In a browser, navigate to VMware Cloud Director Availability FQDN/IP.
In the left pane, click Sites.
Select a cloud site and click Repair.
In the Update Pairing window, click Update.
To complete the trust reestablishment, accept the remote Cloud Service SSL certificate.
Additional Information
For more information on changing user credentials in vCenter Server, see the Change Your vCenter Single Sign-On Password section of the vSphere documentation.