Error "Unable to connect to vCenter" when the Replicator appliance fails to connect to the vCenter Server in VMware Cloud Director Availability
search cancel

Error "Unable to connect to vCenter" when the Replicator appliance fails to connect to the vCenter Server in VMware Cloud Director Availability

book

Article ID: 314993

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:

  • Configuring a new replication in VMware Cloud Director Availability  fails with the error:
Unable to connect to vCenter 'AC3EEE1C-####-####-####-##########CF'.
  • In /opt/vmware/h4/cloud/log/cloud.log on the vApp Replication Manager, you see entries similar to:
2020-02-18 13:43:50.590 ERROR - [UI__0xxxxc4-exx3-4xx8-9xx7-dcxxxxx9c3_xJ] [task-poller-5] com.vmware.h4.jobengine.JobExecution     : Task 0xxx1a-6xxa-4xx0-8xxx-7xxxxx0 (WorkflowInfo{type='start', resourceType='vappReplication', resourceId='C4VAPP-9xxx62-1xx4-403xx5-axx0-04xxxxx2c', isPrivate=false, resourceName='null'}) has failed

com.vmware.h4.replicator.api.exceptions.FailedToAcquireVcConnection: Unable to connect to vCenter 'AC3EEE1C-####-####-####-##########CF'.
  • In /opt/vmware/h4/replicator/log/replicator.log on the Replicator, you see entries similar to:
2020-02-18 13:43:22.503  WARN - [UI__92xxx09-84xxd-xxx-xx-fb46cxxxxcd_rG_Ks_Mb] [https-jsse-nio-8043-exec-5] c.v.h.r.diagnostics.DiagnosticsService   : Can't check vc connectivity, service not configured
...
2020-02-18 13:43:50.578 DEBUG - [UI__0xxxxc4-exx3-4xx8-9xx7-dcxxxxx9c3_xJ_DY_PZ_29] [https-jsse-nio-8043-exec-6] com.vmware.h4.replicator.vc.VcConnector  : Unable to connect to VC AC3EEE1C-####-####-####-##########CF

java.lang.NullPointerException: null
        at com.vmware.h4.replicator.vc.VcConnector.acquire(VcConnector.java:196)

 

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment. 



Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs when lookup service is misconfigured or not set on the VMware Cloud Director Availability Replicator component.

Resolution

To resolve this issue, re-register the Replicator with the same Lookup Service as the other VMware Cloud Director Availability components:
  1. In a browser, navigate to VMware Cloud Director Availability Replicator FQDN/IP.
  2. Log in to the Replicator Management Portal with root user credentials.
  3. In the left pane, click Settings.
  4. Go to Service endpoints > Lookup Service Address and click Edit.
  5. In the pop-up window, enter the Lookup Service address and click Apply.


Additional Information