Error: "Unable to connect to vCenter ..." when configuring replications due to a Lookup Service misconfiguration on the Replicator Appliance
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Error: "Unable to connect to vCenter ..." when configuring replications due to a Lookup Service misconfiguration on the Replicator Appliance

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Article ID: 314993

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Updated On:

Products

VMware Cloud Director VMware Live Recovery

Issue/Introduction

  • Configuring a new replication in VMware Cloud Director Availability  fails with the error:

    Unable to connect to vCenter '########-####-####-####-########ac3e'.

  • In /opt/vmware/h4/cloud/log/cloud.log on the vApp Replication Manager, you see entries similar to:

    ERROR - [UI-########-####-####-####-########a9c3-xJ] [task-poller-5] com.vmware.h4.jobengine.JobExecution     : Task ########-####-####-####-########d7a0 (WorkflowInfo{type='start', resourceType='vappReplication', resourceId='C4VAPP-########-####-####-####-########b62c', isPrivate=false, resourceName='null'}) has failed

    com.vmware.h4.replicator.api.exceptions.FailedToAcquireVcConnection: Unable to connect to vCenter '########-####-####-####-########ac3e'.

  • In /opt/vmware/h4/replicator/log/replicator.log on the Replicator Appliance, you may see entries similar to:

    WARN - [UI-########-####-####-####-########28cd-rG-Ks-Mb] [https-jsse-nio-8043-exec-5] c.v.h.r.diagnostics.DiagnosticsService   : Can't check vc connectivity, service not configured
    ...
    DEBUG - [UI-########-####-####-####-########59c3-xJ-DY-PZ-29] [https-jsse-nio-8043-exec-6] com.vmware.h4.replicator.vc.VcConnector  : Unable to connect to VC ########-####-####-####-########ac3e

    java.lang.NullPointerException: null
            at com.vmware.h4.replicator.vc.VcConnector.acquire(VcConnector.java:196)
            ...

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment. 

Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs when lookup service is misconfigured or not set on the VMware Cloud Director Availability Replicator Appliance.

Resolution

To resolve this issue, re-register the Replicator Appliance with the same Lookup Service as the other VMware Cloud Director Availability components:

  1. In a browser, navigate to VMware Cloud Director Availability Replicator Appliance FQDN/IP.
  2. Log in to the Replicator Service Management Portal with root user credentials.
  3. In the left pane, click Settings.
  4. Go to Service endpoints > Lookup Service Address and click Edit.
  5. In the pop-up window, enter the correct Lookup Service address and click Apply.

Additional Information