"No additional Product support found for the current version" message when checking online for existing product support pack in vRealize Suite Lifecycle Manager
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"No additional Product support found for the current version" message when checking online for existing product support pack in vRealize Suite Lifecycle Manager

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Article ID: 314876

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  •  When checking online for existing product support pack updates you see a "No additional Product support found for the current version" message despite a more recent PSPACK being listed as available as per the vRealize Suite Lifecycle Manager documentation.


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Environment

VMware vRealize Suite Lifecycle Manager 8.x

Cause

The issue can have a number of causes the most common being API request timeouts or stuck requests preventing the engine from correctly processing new requests.

Resolution

To resolve the issue perform the steps below:

1. Snapshot the vRealize Suite Lifecycle Manager appliance as a best practice precaution.

2. SSH to the vRealize Suite Lifecycle Manager appliance and login as root user.

3. Connect to the postgres database:

su - postgres
cd /opt/vmware/vpostgres/11/bin/
./psql -d vrlcm

4. Execute the commands:

DELETE FROM vm_engine_execution_request WHERE enginestatus='SUCCESS';
DELETE FROM vm_engine_execution_request WHERE enginestatus='INITIATED' AND TO_TIMESTAMP(createdon) < NOW() - INTERVAL '1 DAYS';
DELETE FROM vm_engine_user_request WHERE TO_TIMESTAMP(createdon) < NOW() - INTERVAL '2 DAYS';
DELETE FROM vm_lcops_environment WHERE TO_TIMESTAMP(createdon) < NOW() - INTERVAL '7 DAYS' AND status='FAILED';
DELETE FROM vm_rs_request WHERE requestname='lcmgenricsetting';
DELETE FROM vm_engine_event WHERE status='PROCESSED';

5. Check again in the UI to validate if PSPACK is now available in UI to install. If the product support pack is still not available then you can proceed with the API route:

 

To install PSPACK via API:

 

1. Download the relevant Product Support Pack from the Customer Connect website under Product Patches.

2. Upload the patch in the vRealize Suite Lifecycle Manager UI under Settings > Product Support Pack > Upload

3. Obtain the desired product support pack id by referring to the table below

Product Support Pack ID
vRealize Suite Lifecycle Manager, version 8.10.0 Pspack 1

3e461091-601e-4f07-9a1e-275c2186d6aa

vRealize Suite Lifecycle Manager, version 8.10.0 Pspack 2

b889360e-778c-4e50-8572-9a7c67f49e36

vRealize Suite Lifecycle Manager, version 8.10.0 Pspack 3

1ca92f28-6cdf-415e-895f-c0d346be80d8

vRealize Suite Lifecycle Manager, version 8.10.0 Pspack 4

1700328a-21c8-4bb6-9926-3742809c6dc8

vRealize Suite Lifecycle Manager, version 8.10.0 Pspack 5

59fe75cb-729c-4fdf-98af-5c58650ae0a0

vRealize Suite Lifecycle Manager, version 8.10.0 Pspack 6

44760492-dcda-4d3b-af47-c9537f2a189a

vRealize Suite Lifecycle Manager, version 8.10.0 Pspack 7

676dd89c-26f5-47b5-aa25-1a5ac35d5d9b

vRealize Suite Lifecycle Manager, version 8.10.0 Pspack 8

338b2119-cf0c-43ad-9e91-f4d1a925b339

vRealize Suite Lifecycle Manager, version 8.10 Pspack 9

7383acb2-94e1-4bfb-8d95-fc265895833c

vRealize Suite Lifecycle Manager, version 8.10 Pspack 11 e18aac55-85f3-4bf7-9384-83aeb0f65ad3

 

Alternatively if the relevant pack is not contained in the provided table you can obtain the product support pack id by browsing to the url:

https://{{vrlcmfqdn}}/lcm/crepo/explorer/productPatchRepo/patches/vrlcm/{{productversion}}

For example:

https://{{vrlcmfqdn}}/lcm/crepo/explorer/productPatchRepo/patches/vrlcm/8.10.0

Select the relevant product version folder and open the policy.json file to obtain the product support pack id :



4. Once you have the ID open the swagger API UI by selecting the logged-in username in the top right hand corner of the UI then API then then click on LCM Update Controller to view all PSPACK related API's 

 

5. To apply the product support pack select Try it out for the POST /lcm/lcops/api/v2/system-pspack/{pspackId} Apply System PSpack api

6. Enter the pspackid gathered in step 3 and select Execute.

A task should now be visible in the vRealize Suite Lifecycle requests page for PSPACK installation.