NSX-T datasource shows "Data collection failed due to an error. Please wait for some time." in vRealize Network Insight UI
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NSX-T datasource shows "Data collection failed due to an error. Please wait for some time." in vRealize Network Insight UI

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Article ID: 314416

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Updated On:

Products

VMware Aria Operations for Networks

Issue/Introduction

This article provides information on how to fix an issue that prevents flows data from being collected in VMware vRealize Network Insight (vRNI)


Symptoms:
  • Impacted versions of vRNI : 5.x and 6.x
  • When browsing to Accounts and Datasources, you see the above error "Data collection failed due to an error. Please wait for some time" under a NSX-T datasource.

  • On the NSX UI, under Plan & Troubleshoot -> IPFIX -> Firewall IPFIX Profiles, the profile is greyed out and has a status of In Progress

    
  • Collector logs on the vRNI collector show :

    2023-02-18T10:58:30.327Z ERROR dataprovider.utils.HttpUtils NSXT_dataprovider_Config_OpMgr_P
    olicy-0 checkCodeAndThrow:53 Could not get response for /policy/api/v1/infra/ipfix-dfw-profiles/global, status 400
    2023-02-18T10:58:30.327Z ERROR dataprovider.utils.HttpUtils NSXT_dataprovider_Config_OpMgr_P
    olicy-0 checkStatusAndThrow:41 API /policy/api/v1/infra/ipfix-dfw-profiles/global error response {
    "httpStatus" : "BAD_REQUEST",
    "error_code" : 500045,
    "module_name" : "Policy",
    "error_message" : "An object with the same path=[/infra/ipfix-dfw-profiles/global] is marked for deletion.
    Either use another path or wait for the purge cycle (max 5 minutes) for permanent removal of the object."-}
    2023-02-18T10:58:30.327Z ERROR vmware.nsxcommon.AbstractClusterDataSourceFetchUtils NSXT_dataprovider_Config_OpMgr_Policy-0 executeHttpCall:129 Error calling callable for path /policy/api/v1/infra/ipfix-dfw-profiles/_{IPFIX_PROFILE_ID}
    com.vnera.dataproviders.core.common.impl.dataprovider.utils.exceptions.HttpException: Could not get response
    for /policy/api/v1/infra/ipfix-dfw-profiles/global, status 400
 
 


Environment

VMware vRealize Network Insight 6.x
VMware vRealize Network Insight 5.x

Cause

The API /policy/api/v1/infra/ipfix-dfw-profiles/global returns error 400 due to the global profile being marked for deletion.

Resolution

This is a known NSX-T issue : IPFIX Profile is stuck in "In Progress" state and cannot be deleted

Please open a Support Request with "VMware NSX-T Data Center" as a product and a member of the NSX-T support team will assist with the removal of this configuration. 
Once the configuration is removed, the issue shall be resolved in vRNI.