Creation/Migration/Cloning a virtual machine fails with the error: A general system error occurred: PBM error occurred during PreCloneCheckCallback
search cancel

Creation/Migration/Cloning a virtual machine fails with the error: A general system error occurred: PBM error occurred during PreCloneCheckCallback

book

Article ID: 313057

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • Creation/Migration/Cloning a virtual machine or deploying a virtual machine from a template fails with the error:

    A general system error occurred: PBM error occurred during PreCloneCheckCallback: vmodl.fault.systemerror
  • In the C:\ProgramData\VMware\vCenterServer\logs\vmware-vpx\vpxd.log file, you see entries similar to:
     
    --> (vmodl.fault.SystemError) (
    -->        faultCause = (vmodl.MethodFault) null,
    -->        faultMessage = <unset>,
    -->        reason = "PBM error occurred during PreCloneCheckCommonCallback: Fault cause: pbm.fault.PBMFault"
    --> )


  • Note: In vCenter Server Appliance, this log is located at /var/log/vmware/vpxd/vpxd.log file.
     
    <YYYY-MM-DD>T<time> warning vpxd[7F22254CB700] [Originator@6876 sub=Default] Failed to connect socket; <io_obj '0.0.0.0:0' <tcp h:21, p:0x00007f223e0fff00,>, <TCP '127.0.0.1:8190'>>, e: system:111(Connection refused) </io_obj></time>
    <YYYY-MM-DD>T<time> warning vpxd[7F222503A700] [Originator@6876 sub=Default] Failed to connect socket; <io_obj '0.0.0.0:0' <tcp h:21, p:0x00007f223f354be0,>, <TCP '##.##.##.##:8190'>>, e: system:111(Connection refused)</io_obj></time>
    <YYYY-MM-DD>T<time> error vpxd[7F222503A700] [Originator@6876 sub=HttpConnectionPool-000057] [ConnectComplete] Connect failed to <cs p:00007f221d44ffa0, TCP:localhost:8190>; cnx: (null), error: N7Vmacore15SystemExceptionE(Connection refused)</time>
    <YYYY-MM-DD>T<time> info vpxd[7F2224BD8700] [Originator@6876 sub=pbm opID=########-######5A-e1-5] PBMCallback: HasUserDefinedPolicies: PBM error occurred during QueryProfile: Connection refused</time>
    <YYYY-MM-DD>T<time> info vpxd[7F2224BD8700] [Originator@6876 sub=pbm opID=########-######5A-e1-5] PBMCallback: ~PbmFunctionTracer: Leaving HasUserDefinedPolicies</time>
    <YYYY-MM-DD>T<time> error vpxd[7F2224BD8700] [Originator@6876 sub=pbm opID=########-######5A-e1-5] PBMCallback: HandleInternalFaultMessage: PBM error occurred during PreCloneCheckCallback: vmodl.fault.SystemError</time>
    <YYYY-MM-DD>T<time> info vpxd[7F2224BD8700] [Originator@6876 sub=pbm opID=########-######5A-e1-5] PBMCallback: ~PbmFunctionTracer: Leaving PreCloneCheckCallback</time>
    <YYYY-MM-DD>T<time> error vpxd[7F2224BD8700] [Originator@6876 sub=VmProv opID=########-######5A-e1-5] [CallbackManager] Got exception while invoking precheck on PbmCallBack: vmodl.fault.SystemError</time>
    -->
    --> [backtrace begin] product: VMware VirtualCenter, version: 6.0.0, build: build-2559267, tag: vpxd
    --> backtrace[00] libvmacore.so[0x003C0094]: Vmacore::System::Stacktrace::CaptureWork(unsigned int)
    --> backtrace[01] libvmacore.so[0x001EDBA3]: Vmacore::System::SystemFactoryImpl::CreateQuickBacktrace(Vmacore::Ref<Vmacore::System::Backtrace>&)
    --> backtrace[02] libvmacore.so[0x001988AD]: Vmacore::Throwable::Throwable(std::string const&)
    --> backtrace[03] vpxd[0x00BD070E]: Vmomi::Fault::SystemError::Exception::Exception(std::string const&)
    --> backtrace[04] vpxd[0x01799FAA]: PbmService::HandleInternalFaultMessage(Vmacore::Exception*, std::string const&, Vpx::Vmprov::Context*) const
    --> backtrace[05] vpxd[0x01792D63]
    --> backtrace[06] vpxd[0x01CDD99B]
    --> backtrace[07] vpxd[0x01D47F16]
    --> backtrace[08] vpxd[0x01D5E00D]


    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.



Environment

VMware vCenter Server

Cause

This error occurs when the Profile-Driven Storage service is not running or is not accepting connections.

Note: This service is also called Policy Based Management(PBM).

Resolution

To resolve the issue, ensure that the Profile-Driven Storage service is running.

For vCenter Server Appliance :

  1.  SSH to the VCSA using PuTTY or similar SSH client.
  2. Enter the shell of the vCSA. (If the prompt shows command> that is the appliance shell. The below commands cannot be ran in appliance shell.)
  3.  Run this command to check the status of the service:

    service-control --status vmware-sps
     
  4. Run this command to start the vmware-sps service:

    service-control --start vmware-sps
     
  5. Run this command to restart the vmware-sps service:

    service-control --restart vmware-sps
Note: For more information on starting or restarting a vCenter Server Appliance 6.x service, see Stopping, starting, or restarting VMware vCenter Server Appliance 6.x services.

For vCenter Server:
 
  1. Log in as an administrator to the server that is running vCenter Server.
  2. Click Start > Run, type services.msc and Click Ok.
  3. From the list of services, check the status of the Profile-Driven Storage service.
Alternatively:
  1. Open command prompt as administrator
  2. Change directories (replace letter C with the appropriate letter driver)

cd C:\Program Files\VMware\vCenter Server\bin

  1. Run this command to check the status of the service:

    service-control --status vmware-sps
     
  2. Run this command to start the vmware-sps service:

    service-control --start vmware-sps
     
  3. Run this command to restart the vmware-sps service:

    service-control --stop vmware-sps;service-control --start vmware-sps


Additional Information