Error "Operation timed out" while reconfiguring HA (FDM) on a cluster
search cancel

Error "Operation timed out" while reconfiguring HA (FDM) on a cluster

book

Article ID: 313030

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

The purpose of this article is to resolve Error - operation time out while configuring HA.

Symptoms:

  • Cannot reconfigure HA on a cluster.
  • Reconfiguring HA on a cluster fails.
  • You see the errors:
    Operation timed out
or
Cannot find vSphere HA master agent
when there are no networking or other issues preventing host to host communication within the cluster

 

  • Removing the ESX host from the cluster and then adding it again to the cluster does not resolve the issue
  • You see this error in the Task Details pane in vCenter Server:
    Status: Operation timed out.
     
  • You may see these related events:
    • vSphere HA agent on <<Host's Name>> in cluster <<Cluster's Name>> in <<Datacenter's Name>> is disabled
    • The vSphere HA availability state of the host <<Host's Name>> in cluster <<Cluster's Name>> in <<Datacenter's Name>> has changed to Uninitialized
    • The vSphere HA availability state of the host <<Host's Name>> in cluster <<Cluster's Name>> in <<Datacenter's Name>> has changed to Initialization Error
    • vSphere HA agent for host <<Host's Name>> has an error in <<Cluster's Name>> in <<Datacenter's Name>>: vSphere HA agent cannot be correctly installed or configured



Environment

VMware vCenter Server Appliance 6.5.x
VMware vCenter Server 6.5.x
VMware vCenter Server 6.0.x
VMware vCenter Server 6.7.x
VMware vCenter Server Appliance 6.0.x
VMware vCenter Server 7.0.x
VMware vCenter Server Appliance 6.7.x
VMware vCenter Server 8.0.x

Cause

This issue occurs if the vSphere High Availability Agent service on the ESXi host is stopped.

Resolution

To resolve this issue:
  1. Disable HA on the cluster.
  2. Select the host and click the Configuration tab.
  3. Click Security Profile / Services
  4. Click Properties and check the status of vSphere High Availability.
  5. Start the service if it is stopped.
  6. Enable HA on the cluster. You should now be able to reconfigure HA.

Note: If jumbo frames are configured then make sure you are able to ping the vmkernel with a minimum of 9000 packet size. For more information see, Testing VMkernel network connectivity with the vmkping command.

Additional Information