Error: "vSphere HA agent cannot be correctly installed or configured"
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Error: "vSphere HA agent cannot be correctly installed or configured"

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Article ID: 318929

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Updated On:

Products

VMware vSphere ESXi VMware vSphere ESX 8.x

Issue/Introduction

Information on how to troubleshoot and fix vSphere HA not configuring on ESXi hosts.

Symptoms:
  • Unable to install or update the vCenter Server vSphere High Availability (vSphere HA) agent service.
    • The vmware-fdm VIB is the package that runs this service on each ESXi host
  • Powering on virtual machines fails with error:
    The host is reporting errors in its attempts to provide vSphere HA support
  • In the VMware vCenter Server summary, the following vSphere HA service error may be observed:
    vSphere HA agent for this host has an error: vSphere HA agent cannot be correctly installed or configure


Environment

VMware vSphere ESXi 6.5, 6.7, 7.0, 8.0


Cause

Some things that can cause this issue include:
  • ESXi host problem with third-party VIB (such as a compatibility issue)
  • ESXi host heartbeat datastore problems
  • ESXi host OS problems
  • vCenter Server OS problems
  • vCLS related issues

Resolution

To resolve this issue: 
  1. If the error is "vSphere HA agent is unreachable" follow vSphere HA agent is unreachable and the Summary tab of the ESXi host reports the error: vSphere HA reports that an agent is in the Agent Unreachable state
  2. If the ESXi host is in a vSAN cluster, ensure:
    1. Its networking is configured for, and participating in the vSAN cluster.
    2. It is showing good health for vSAN per Check vSAN Health.
  3. Disconnect, then reconnect the ESXi host to vCenter
    1. In the vCenter GUI, use the Hosts and Clusters view
    2. Right-click the ESXi host and select Connection > Disconnect
    3. Right-click the ESXi host and select Connection > Connect
    4. Disable, then re-enable vSphere HA for the cluster per Configuring vSphere Availability Settings.
  4. If the problem persists, check whether the vSphere HA agent service needs to be restarted per Reconfiguring HA (FDM) on a cluster fails with the error: Operation timed out.
  5. If the problem persists, restart the vSphere HA service on the cluster
    1. Turn vSphere HA off for the whole cluster per Disabling VMware High Availability (HA).
    2. Turn vSphere HA back on for the whole cluster per Enable vSphere HA and vSphere DRS in ESXi
  6. If the problem persists, try putting the cluster in retreat mode and taking it out again per How to Disable vCLS on a Cluster via Retreat Mode.
  7. If the problem persists, check whether the ESXi host version is compatible with the vCenter Server version per the VMware Product Interoperability Matrix.
    1. If not compatible, upgrade the software accordingly.
    2. If upgrading ESXi hosts, always check the VMware Compatibility Guide to ensure the server hardware is compatible with the new ESXi version.
  8. If the problem persists, follow ESXi host not responding , /tmp folder 100% to check and resolve if the ramdisk /tmp directory is full.
  9. If the problem persists, review the /var/run/log/fdm-installer.log file:
         cat /var/run/log/fdm-installer.log |less
         bootbank_qlogic_hcli_2.2.60.7.0.0vmw.500.0.0.472560 violates extensibility rule: Installing the VIB
         fdm-installer: [24683] 2013-07-18 18:41:45: Result of esxcli software vib install -v=/tmp/vmware-root/ha-agentmgr/vpx-upgrade-installer/vmware-fdm.vib: [DependencyError]
         fdm-installer: VIB QLogic_bootbank_qlogic_hcli_2.2.60.7.0.0vmw.500.0.0.472560 violates extensibility rule checks: [u'(line 31: col 0) Element vib failed to validate content']
         fdm-installer
  • If an error in the fdm-installer.log indicates that a reboot is needed, then the host will need to be rebooted
  1. If the problem persists, check for heartbeat datastore problems per Troubleshoot ESXi heartbeat datastore problems affect vSphere HA.
  2. If the problem persists, restart the Platform Services Controller (if vCenter uses an external PSC). Once it finishes rebooting, then restart the vCenter Server managing the ESXi host.  Note: Versions 7.x have no external PSC, it is always embedded into vCenter
  3. If the problem persists, rule out network issues
    1. Ensure that the ESXi host vmnics MTU size is consistent across all switch ports and other infrastructure that allow MTU configuration.
    2. Ensure that no firewall changes were made to the ESXi host or network switches that could be blocking ports 80, 443, or 902 between hosts and vCenter Server.
  4. If the problem persists, restart the management agents on the ESXi host per Restarting the Management agents in ESXi.
  5. If the problem persists, follow the bottom half of the article Resolve third-party VIB preventing vSphere HA agent updates, starting at "To remove the vSphere HA agent VIB".
  6. If the problem persists, reboot the ESXi host.

Additional Information



Impact/Risks:
When an ESXi host cannot install or configure the vSphere HA agent, VMs may not vMotion to it or may not restart on another ESXi host if the problem ESXi host fails.
Restarting management agents on ESXi hosts presents the risk that the agents don't fully restart. In this situation, the running VMs on the host may need to be shut down and ESXi host may need to be rebooted to recover.

This issue is being checked by Diagnostics for VMware Cloud Foundation.

The check is as follows:

  • Product: ESXi
  • Log File: fdm-installer.log
  • Log Expression Check "Result of esxcli software vib install" "vmware-fdm.vib\" AND "DependencyError"