False alarm "Edge VM Present in NSX Inventory Not Present in vCenter" reported by NSX manager
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False alarm "Edge VM Present in NSX Inventory Not Present in vCenter" reported by NSX manager

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Article ID: 311860

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Edge VM has been removed and is no longer present in the vCenter or ESXi host inventory.
  • On the NSX-T manager > Inventory tab > Virtual Machines you can confirm the Edge VM does not exist.
  • NSX-T manager alarm reports "Edge VM Present in NSX Inventory Not Present in vCenter".

Environment

VMware NSX-T Data Center
VMware NSX

Cause

The issue occurred due to a stale entry related to the Edge VM in the Corfu database table following its deletion.

Resolution

This issue is resolved in VMware NSX 4.2.0 and later, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

Workaround:
Restart the proton service on each manager node to ensure the monitoring cache is cleared.

  1. Log in to the NSX Manager appliance using root.
  2. Restart the proton service by running the below command:
    service proton restart
  3. Perform a rolling reboot of the NSX Managers and the Edge VM nodes if Step 2 does not resolve.

Additional Information