Change the default console session timeout in SOI (Global setting)
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Change the default console session timeout in SOI (Global setting)

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Article ID: 31001

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

We have a need to stay logged into the SOI console for an extended period of time.

But users are logged out every night, and have to login again the next morning.

Environment

Release: Service Operations Insight SOI 4.2

 

Cause

The default session timeout in EEM (SOI uses EEM for authentication) is 24 hours.

However, this can be customized.

This document explains the steps to provide a custom session timeout.

Resolution

On the EEM Server:

Stop the 'CA iTechnology iGateway' service in the windows services GUI:

 Or run

net stop "CA iTechnology iGateway 4.7"

 

Browse to

C:\Program Files\CA\SC\iTechnology

Make a copy of iAuthority.conf (original.iAuthority.conf)

Open iAuthority.conf

Add "<CredentialLifeTime>N</CredentialLifeTime>" before the </iSponsor> tag.

 

Note: N is the number of hours to set the expiration time to. You can increase or decrease the timeout value according to your requirement.

 

Original file:

</TrustedRoot>

</iSponsor>

 

Edited file:

</TrustedRoot>

         <CredentialLifeTime>168</CredentialLifeTime>

</iSponsor>

 

 

Start the 'CA iTechnology iGateway' service in the windows services GUI:

 Or run

net start "CA iTechnology iGateway 4.7"

 

Additional Information

NOTE - This is a Global setting and applies to all users.

For changing the timeout for users see SOI Console auto logout timeout setting for user (broadcom.com)