NGINX service fails to start with error message "Timeout while contacting DNS servers"
search cancel

NGINX service fails to start with error message "Timeout while contacting DNS servers"

book

Article ID: 288660

calendar_today

Updated On:

Products

Carbon Black EDR

Issue/Introduction

  • When Carbon Black EDR cb-enterprise services are started, NGINX service fails to start.
  • Enterprise.log example:
    start_time=1388538908&server_token=fWwfogR6Xy24DU3Pw9D2l4Wrm3spj1fy (Caused by <class 'socket.gaierror'>: [Errno 12] ARES_ETIMEOUT: Timeout while contacting DNS servers)

Environment

  • Carbon Black EDR Server: All Supported Versions

Cause

This can result from incorrect DNS entries or if the DNS is not reachable by the server.

Resolution

  1. Navigate to /etc/resolv.conf and make sure both IP and FQDN are added into the conf file.
  2. Verify if "nslookup" in both forward and reverse lookup is resolving.
  3. Once the DNS errors are cleared, restart EDR services