Solr Fails to Start with "This version of Lucene only supports indexes created with release 4.0 and later"
book
Article ID: 288031
calendar_today
Updated On:
Products
Carbon Black EDR (formerly Cb Response)
Issue/Introduction
Solr is failing to start.
/var/log/cb/solr/debug log shows a similar error
BufferedChecksumIndexInput(MMapIndexInput(path="/var/cb/data/solr/cbfeeds/data/index/segments_9m4"))): -1682135807 (needs to be between 1071082519 and 1071082519). This version of Lucene only supports indexes created with release 4.0 and later.
Environment
Carbon Black EDR Server: All Versions
Cause
Index corruption
Resolution
Log in to the back end server via SSH/Terminal session
Navigate to the directory listed in the error message
Rename the index folder (Note: Using the example path from the error above where the path is for the cbfeeds core)