Agent Upgrade Error in Console "Upgrade installer ended without stopping the agent"
book
Article ID: 286649
calendar_today
Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
When upgrading the Agent via the Console the upgrade fails and the error returned to the Computer Details page in the Console shows:
"Agent upgrade: Failed executing Installer[c:\programdata\bit9\parity agent\parityhostagent.msi] Cmdline[User[NT AUTHORITY\SYSTEM]]. Upgrade installer ended without stopping the agent."
Environment
App Control Agent: All Supported Versions
App Control Console: All Supported Versions
Microsoft Windows: All Supported Versions
Cause
There are many reasons why this message could be displayed, these include:
Failure of the Code Signing/Counter Signing certificates used to validate the ParityHostAgent.msi file.
Remnants from a previous Agent installation, preventing the upgrade.
Some other Pre-installation Check failing, causing the Agent to not upgrade.
Resolution
The full ParityHostAgentInstall_TIMESTAMP.log file on the endpoint should be reviewed for further confirmation, however some common ways to resolve these issues include:
If the upgrade continues to fail please collect the full upgrade log from the endpoint open a case with Technical Support and provide a copy of the failed log from the endpoint, which should be located in: