Agent Upgrade Error in Console "Upgrade installer ended without stopping the agent"
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Agent Upgrade Error in Console "Upgrade installer ended without stopping the agent"

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Article ID: 286649

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

When upgrading the Agent via the Console the upgrade fails and the error returned to the Computer Details page in the Console shows: 
"Agent upgrade: Failed executing Installer[c:\programdata\bit9\parity agent\parityhostagent.msi] Cmdline[User[NT AUTHORITY\SYSTEM]]. Upgrade installer ended without stopping the agent."

Environment

  • App Control Agent: All Supported Versions
  • App Control Console: All Supported Versions
  • Microsoft Windows: All Supported Versions

Cause

There are many reasons why this message could be displayed, which may include:

  • Failure of the Code Signing/Counter Signing certificates used to validate the ParityHostAgent.msi file.
  • Remnants from a previous Agent installation, preventing the upgrade.
  • Some other Pre-installation Check failing, for which the Agent service will not stop

Resolution

  1. Verify the Agent Exclusions are in place with other antivirus/security/scanning software: Antivirus Exclusions for the Agent
  2. Most commonly, Registry Keys from previous versions will cause a failed pre-upgrade or pre-install check.
  3. Verify Add/Remove Programs shows only one version of the Agent installed.
  4. Issue a Global Approval for the new hash of the ParityHostAgent.msi file, and remove the pending Upgrade Attempt to allow the Agent to receive the new Approval.
  5. Test manually upgrading an Agent via the command line.

If the issue persists please follow the additional steps in Troubleshooting Agent Install or Upgrade Issues