Agent Upgrade Error "Postponed until system updates are completed"
search cancel

Agent Upgrade Error "Postponed until system updates are completed"

book

Article ID: 286486

calendar_today

Updated On: 04-01-2025

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Agents failing to upgrade
  • Upgrade error "Postponed until system updates are completed" shown in "upgrade status" column

Environment

  • App Control Console: All Supported Versions
  • App Control Agent: All Supported Versions
  • Microsoft Windows: All Supported Versions

Cause

If a process related to Windows Updates (example: TrustedInstaller.exe or wuauclt.exe) has been running for at least 5 minutes, and has written data within the last 15 minutes, the Agent returns this status. 

Resolution

The update will attempt again once the Windows Updates timeout criteria is met. Alternatively, the following steps can be used to either reduce the timeout or disable the check entirely:

Reduce Update Timeout: Default is 15 minutes, this changes it to 5 minutes

  1. Log in to the Console and navigate to https://<ServerAddress>/agent_config.php
  2. Click Add Agent Config and use the follow details:
    • Property Name: Windows Update Active Write Timeout
    • Host ID: 0
    • Value:
      windows_update_active_interesting_write_ms=300000
    • Platform: Windows
    • Status: Enabled
    • Create For: All Current and Future Policies
  3. Save
  4. Remove the Agent Upgrade Request, verify Agent shows Up to Date and re-attempt.

Disable Windows Update Check:

  1. Log in to the console and navigate to https://<ServerAddress>/shepherd_config.php
  2. Select the Property: UpgradeOptionFlags
  3. Change the Value to 1
  4. Remove the Agent Upgrade Request, verify Agent shows Up to Date and re-attempt.