You Have Exceeded Your License Limit Warning in App Control Console
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You Have Exceeded Your License Limit Warning in App Control Console

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Article ID: 284758

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

Error message in the Administration > System Configuration > Licensing tab states license limit is exceeded

Environment

  • App Control Console: All Supported Versions
  • App Control Agent: All Supported Versions

Cause

Total Computers in the Console exceeds the Endpoint Limit for the current Server License.

Resolution

  1. Verify Old Computer Cleanup is Enabled and configured correctly:
    1. Log in to the Console and navigate to Settings > System Configuration > Advanced Options.
    2. Click Edit and configure Old Computer Cleanup accordingly.
    3. Click Update.
  2. Verify Clone Cleanup Settings are configured correctly:
    1. Log in to the Console and navigate to Assets > Computers.
    2. Filter on, or locate and view the relevant Template Computer(s).
    3. From the Template Details page choose the tab: Template Settings and adjust the Clone Cleanup settings accordingly.
  3. If changes were made: manually run the DailyPruneTask or wait for the next scheduled execution.
  4. Work with the Account Team to purchase additional licenses accordingly.

Additional Information

  • Agents that are deleted from Assets > Computers will be added back automatically once the Agent reconnects to the Server.
  • Endpoint Limit is based on Agents in a Policy that uses Visibility or any of the Control Modes: Low, Medium or High.
  • Exceeding the Endpoint Limit will not:
    • Impact the ability to log in to the Console.
    • Automatically disable or uninstall Agents.
    • No change is made to the Agents; they will continue using the specified Enforcement Level, Approvals and Custom Rules.