High battery usage on Android phones
search cancel

High battery usage on Android phones

book

Article ID: 282649

calendar_today

Updated On: 07-23-2024

Products

Endpoint Protection Mobile

Issue/Introduction

When you are getting reports of higher-than-expected battery usage attributed to the SEP Mobile app on Android phones.  This article will discuss data which can be collected to investigate this condition.  

Environment

SEP Mobile app running on a Android. 

Cause

Unknown - due to the low volume of reports, and intermittent nature of the behavior in those cases, nothing conclusive has been discovered regarding this issue.  

Resolution

If this concern is reported, please work with the impacted user to perform the following data collection procedure: 

1.) Charge the phone to 100%. 
2.) Use the phone normally over a period of several days, draining the battery as low as possible (ideally to around 10%).  
3.) Prior to charging the phone, capture the following data: 

  • Screenshot of Settings > Battery > Battery Usage > "Battery level since last full charge" - usage over time graph
  • Screenshot of Settings > Battery > Battery Usage > "Battery level since last full charge" - View by apps list (please capture multiple pics if needed to include the entire apps list) 
  • Send the SEP Mobile app log - https://knowledge.broadcom.com/external/article/172294/collect-and-send-logs-endpoint-protectio.html
    (Note - when submitting a Mobile app log, if you do not already have a case number, please use "battery" for the case number.) 

4.) Repeat steps 1 through 3 two more times, for a total of three data sets to be submitted.